get_iplayer forums

Full Version: RPi with USB pen drive: "Failed to open file /media/iplayer/program_name.mp4" error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Please bear in mind my Linux skills are nowhere near where I'd like them to be, but I do try (well, my missus says I'm trying), so please bear with this "ramble", as I will be very grateful of any guidance you can offer. 

I am (or have been) running get-iplayer on a Raspbian Pi 2B for a couple of weeks, and a grand thing it is too. All went well originally, recording & running the mp4 files, until I bought a usb pendrive to increase the storage space for iplayer. I then became ambitious, I made the mount point persistent using an fstab entry and also "changed" the output to /media/iplayer (the mountpoint for the usb stick) using 'get_iplayer --prefs-add -o /media/iplayer'. 
Now, however, I can search & refresh the cache using the CLI or Web_PVR but whenever I try to record one or a number of shows I get the error mentioned in the title, again using either web-pvr or cli. 
I have tried uninstalling and purging get_iplayer but to no avail, and re-installing but still have the same error. I have to say that the purge didn't seem to work too well, as when I look in /.get_iplayer in my home directory immediately after re-install the options file still has the prefs-add value I originally made. 
As an addendum, I'm running the Pi via rdp from my W*****s 8.1 laptop, so a quick cut and paste is not an option, as I'd have to shift the kit around.
May thanks to all you good folks, who give of their time & abilities to help over-ambitious GOG's such as myself, restores one's faith in human nature.

Edit: Sorry about not adding detail. Please see attached (I hope!)[attachment=165] file
Don't paraphrase or condense get_iplayer's output. Capture it all in a text file (.txt) and post it as an attachment. Yes, it makes a difference. An MP4 file gets opened more than once, so without a proper report we have no idea where the problem may lie.
Just to let you know, I've re-installed Raspbian, get-iplayer and omxplayer, and all seems to be well again. Many thanks for taking the time to consider my problem. I do appreciate it. Hope it hasn't caused too much work/effort/grief to anyone