get_iplayer forums

Full Version: problem getting episodes after 7 days
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am having the same problem with all series, downloading episodes after 7 days.
I tried downloading by pid or url and neither worked. No episode detected.
I can watch episodes through flash plugin and browser only.
The search index has also changed.
What commands do I need to use now?
Before anybody responds without investigating, it appears that now whole series are online for a month after transmission and I can watch them in a browser but not stream them with get_iplayer.
Hi piddigger,
We know programmes are now available for 30 days and changes have been made to make use of this. We also know that the feeds get_iplayer used for the cache have now been removed

First thing for you to do is update to the latest version of get_iplayer which contains fixes for things that the change to 30 day availability broke.

At the moment you can ONLY download programmes by PID (one at a time) as there is no search index to download from.

Dinky Pumpkin plans to release an interim update tomorrow which will hopefully restore some of the search index and will allow you to download multiple PIDs in one go.