get_iplayer forums

Full Version: get_iplayer folder doesn't show up under Start Menu (Win7)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I am trying to install "get_iplayer" on Win7, following the instructions given on this website. The installation seems to run through smoothly. Only, I don't have the "get_iplayer" folder in my Windows Start Menu.

I can see the folder containing what I think is everything there needs to be in there. Searching for "get_iplayer" only shows me a ".get_iplayer" folder which doesn't have anything useful in it.

I tried uninstalling and reinstalling and turned on the log details. I seem to see some sort of an error message after every line that reads "Extracting contents of ...", only the error message is always followed up by some garbage characters that don't tell me much.

I tried to trace the errors in the Win7 "Event Viewer" but didn't see anything there.

Does anyone have a suggestion for what I might be doing wrong? I did look through the Windows forums and didn't find anything relevant to my problem, but my apologies if I may have missed seeing something directly related there.

Figured out the source of the "problem":

I was logged in as a normal user and selected the option "Run as Administrator" when installing. The installation ran fine but no folder was created in the Windows Start Menu. I was however able to run the program from the folder where it was installed, well, almost until I got the error message that I didn't have permissions to overwrite an existing folder (The one on the admin account of course, as that was set as the default destination).

So, the solution would be to temporarily change the user account type to "Administrator". This gets me the entry in the Start Menu. As far as using the program is concerned, I still could run it off the command window even otherwise as long as the destination folder was not in the admin user's space. That's all.

A newbie error that one.

Unfortunately, the installer is not really multi-user friendly. It installs shortcuts and sets the output dir by default for the effective user running the installer. If you've gained elevated privileges from a different user account, things get messed up as you described. You can hack things to work properly, but really the installer needs some work. As you noted, the best thing to do for now is to install while logged in as a user with Administrator privileges.