get_iplayer forums

Full Version: Access Denied error on Windows
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just tried to download a programme and got the message that the content is not available. After updating the program to the latest version, the message now reads simply access denied which suggests to me it is related to now needing to sign in to use the iplayer.

The code I input was this..   get_iplayer --pid=b096jjqk

It is a radio show.

I tried again with the blue planet using this but same problem...   get_iplayer --pid=p04thmv7

While upgraging to the newer version an error message came up saying perl.exe could not be extracted which could be related, but as I said it was already failing to download using the previous version before this.

How can this be resolved and how is get iplayer supposed to be able to download anything now since this sign in wall has gone up? I was already signed in to iplayer with the same ip i was trying to download through also.

This has nothing to do with BBC sign-in. You appear to have a broken installation and/or permission problems. Uninstall, reboot, re-install. If the same thing happens, post a screen grab of the error.
Re-installation worked. Thanks for you help!