get_iplayer forums

Full Version: Problem finding TV Programs
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I wonder if someone could put me straight with searching for TV programs within the Web PVR. I have just updated to v3.06 after few new tv programs were being added to the cache. (I have since found on this forum that an upgrade to 3.06 was indeed necessary as the BBC broke the system!)

However even with the update installed I cannot find more than 297 TV programmes in the cache. I am trying to record the latest Blue Planet II: Series 1 but whatever criteria I search for in the web PVR it does not bring back a result. I have tried searching for:-
1) Name using Blue Planet II: Series 1 and Blue Planet II and Blue Planet none of which bring back a result
2) Pid using p04tjbtx which is the series Pid and also p04thmv7 which is the first episode Pid
3) By URL using both http://www.bbc.co.uk/programmes/p04tjbtx which is the series URL and https://www.bbc.co.uk/iplayer/episode/p0...-one-ocean Which is the first episode URL ( Interestingly previously URLs ended in the Pid but now an episode url ends with the episode title! I am not sure if this is s recent change)
I can download the Episode by using get_iplayer --Pid=p04thmv7 typed directly into a terminal window so get_iplayer itself is working. It says 0 Matching Programs in Info but continues to download anyway.
However I want to download all episodes without having to search for each one in a browser first to find the pid.
I am using Chromium build 62.0.3202.62 on Ubuntu 16.04 (Xubuntu)

I have refreshed the cache numerous times both from the Web PVR and from Terminal but it makes no difference and does not bring back any more than the original 297 programs

Am I doing something wrong?
Many thanks
Fozzie
Using web pvr manager in windows 10 x64 it shows up with the following search

^Blue Planet II: Series 1$

according to the search it was added to my cache 20 hours ago.
That's what I would have expected. I cant even find other programmes such as My Girl. I think its something to do with the cache even though I keep refreshing it I still only get 297 programmes.
Can you tell me what terms you used to search the cache to bring back a hit. i.e. what name exactly..... Blue Planet, Blue Planet II, Blue Planet II: Episode 1 etc etc

Many thanks
Fozzie
Any one of those options should bring up the episode, I used "Blue Planet II" and it worked fine for me.

To answer the query you had regarding the URL. If you look up the BBC programme schedule pages you will still see http://www.bbc.co.uk/programmes/p04thmv7 for this first episode. And the same is true if you access the BBC's iPlayer pages before the programme is aired, it shows the same URL, however here, if you access the same pages after the programme has been aired and appeared on iPlayer then the URL is changed to include the programme name. This has been the case for some time now, at least a year or more. For this reason I prefer to go to the programme schedule pages, as it makes things a bit easier for me.

You can download using get_iplayer --get "Blue Planet" or get_iplayer --pid p04tjbtx --pid-recursive. In both cases, you will get all episodes still available on iPlayer that you have NOT YET downloaded. Using the --pid-recursive option, I notice for Blue Planet you will also get the trailer for the next programme.

I suspect it's an options issue that you're experiencing, but as I don't have Ubuntu I'll wait for someone else to advise.
try rebuilding the cache ..... get_iplayer --cache-rebuild --type=tv,radio
Many thanks harlequin1963, That did it. It added nearly 7000 TV entries into the cache and I can now search and find all the tv programs I was missing.
Not sure why refreshing the cache did not do the same thing but one to remember for the future.

Many thanks
Fozzie