Not a scalar reference error at get_iplayer.pl line 7099 on Shark Episode 1
#1
I have downloaded Shark Episodes 2 and 3 but for Episode 1 I get "Not a scalar reference ..." error. I have tried

get_iplayer --get 1277
get_iplayer --pid p02n7sc6

and also used the web pvr manager using 1277 as the index. In all cases it correctly identifies the programme
but I get the error:
Info 1: matching programmes
Nor a scalar reference at get_iplayer.pl line 7099

I see this issue should be fixed in the next release but others say if you try enough times it eventually works. I have tried about 15 times with no luck. By the time of the next release of get_iplayer the programme will no longer be available. (I have v 2.92)

Any suggestions?
Thanks.
#2
A new release will be available in a day or two, so you will have time to get episode 1
#3
You may be able to work around this error by trying either
Code:
--exclude-supplier=akamai
or
Code:
--exclude-supplier=limelight
#4
I did try setting flashhd1 and flashhd2 to see if that would force a different CDN but it made no difference.
#5
Changing the recording modes won't make any difference. Try what I suggested. Use
Code:
--exclude-supplier=akamai
to get the above episode of Shark.
#6
Thanks for that work around, it worked fine for:

Storyville - Ziggy Stardust and the Spiders from Mars
#7
With all these bad HLS playlists, does that cause longer term problems when it comes to using the HLS download options? If and when on-demand TV and radio switch to HLS streaming, will the bad playlist data cause these to fail?
#8
A lot of those errors were spurious (get_iplayer bug), and they are now suppressed without
Code:
--verbose
. The HLS playlists have changed a bit recently, but there is no way to know what that portends for the future. I haven't investigated. However, some of the errors were the result of access to a few playlists being explicitly denied by the BBC CDN. If they were all shut off, then that certainly would be a problem
#9
Why did they suddenly start appearing like that though after the Beeb turned the ION feeds off? There had been the occasional HLS playlist error over the past weeks but suddenly everything seemed to have them.

When you say the requests were denied by the BBC CDN, was that denied to get_iplayer in particular or just denied in general.

Presumably they can't remove all these playlists because the mediaselector itself must need them to actually play the content.
#10
Like I said, I haven't investigated. That's a headache for another day. Presumably there were some CDN changes along with the other shenanigans. It may have something to do with rolling out a new streaming platform at one of the CDNs.
#11
I haven't tried the workaround but I have installed 2.94 and now get a different error:

INFO: File name prefix = Shark_-_1._Episode_1_p02n7sc6_default
RTMPDump v2.4
(c) 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
ERROR: Last tag size must be greater/equal zero (prevTagSize=873189259) and smaller then filesize, corrupt file!
INFO: Command exit code 1 (raw code = 256)
WARNING: Retry recording for 'Shark - 1. Episode 1 (p02n7sc6)'

It retries indefinitely.

Any suggestions.

Should I try the workaround (--exclude-supplier=Akamai) with 2.94 or do I need to revert to 2.92 for that to work?

Thanks
#12
Just tried again with 2.94 and the workaround. Seemed to get the same error but this time I left it running and after about 30 retries it started downloading. Probably nothing to do with the workaround. Anyway I have now got all three episodes. Thanks for your help.
#13
Looks like you may already have a partial download of it somehow in your downloads folder. You need to delete that first.
#14
Spoke too soon - its the signed version. Just tried again (without the workaround but with --force because it was already in my history). It took about 100 retries this time but started downloading in the end, but now I am getting the audio described version! What is going on?
#15
Worked it out. There was already a partial .flv file of the episode in the recordings folder (presumably from previous failed attempts) so get iplayer looked for an alternative version. That's probably why it took all those retries.
#16
Quote:Dinky Pumpkin wrote:Changing the recording modes won’t make any difference. Try what I suggested. Use
Code:
--exclude-supplier=akamai
to get the above episode of Shark.

Quote

Thanks for that advice, I was having probs downloading a BBC 4 film "An Education" which resulted in a similar "Not SCALAR" response, Googling for help brought me here and success ..Thanks!
How will we mere mortals know when there is an update to get_iplayer?
#17
Releases are announced here in the forums, on the blog and in the get_iplayer mailing list.

Visit any of those (or subscribe to the blog/mailing list) and you'll be notified.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Web PVR fails with "cannot fork at get_iplayer.cgi line 328" alansh 1 2,543 15-06-2015, 12:05 PM
Last Post: dinky
  Version 2.87 fails to even start up - issue with get_iplayer.pl line 74 DNay 1 2,445 19-10-2014, 10:49 PM
Last Post: dinky