No shows at all in index feed
#1
I use the pvr functionality with cron on Ubuntu to download various radio shows.
Just recently (within the last few days or so) I've noticed that my cron job hadn't picked up any shows for me to listen to.

I went to investigate, and when I run a "blank" search manually with "get_iplayer --type radio" there is only 1 result being displayed:

<pre>
Code:
$ get_iplayer --type radio
get_iplayer v2.87, Copyright (C) 2008-2010 Phil Lewis
  This program comes with ABSOLUTELY NO WARRANTY; for details use --warranty.
  This is free software, and you are welcome to redistribute it under certain
  conditions; use --conditions for details.

Matches:
10001:    BBC iPlayer Feeds - -, BBC Radio Nan Gaidheal, Highlights,Popular

INFO: 1 Matching Programmes
</pre>



Any attempt at searching for shows I know have been broadcast within the last 7 days gives no results whatsoever.

I've cleared my cache and forced a refresh but there doesn't appear to be any shows (TV or radio) being shown any more. I can however still download manually using "--pid" but I have to manually search the iplayer site to get these. My cron job coupled with the pvr searches was a handy automatic way of periodically receiving content to be enjoyed offline without any intervention.

Has something changed I'm not aware about? I know about the new 7-day limit, but this seems like a different matter altogether...

I've tried 2.87 and also checked out the latest with
Code:
git clone git://github.com/get-iplayer/get_iplayer
to no avail.
#2
Broken by the BBC:

https://squarepenguin.co.uk/forums/topic...available/
#3
Ah. I see! Well, that would certainly explain it. Sounds pretty impossible to fix...

In the meantime, does anyone know of any other indexing resource (perhaps another website) that keeps lists of PIDs matched to radio shows? That data must be within the iPlayer website somewhere, but I have no idea how to formulate the correctly formatted request to display it.
#4
http://www.iplayerconverter.co.uk/default.aspx
#5
The PIDs are also embedded in the episode URLs on the iPlayer Radio site
#6
Many thanks...


Possibly Related Threads…
Thread Author Replies Views Last Post
  podcast feed is not downloading InAFlap 7 6,820 13-08-2015, 01:35 PM
Last Post: dinky
  Failed to record and no index feed. Tilly37 4 5,232 13-06-2015, 06:50 PM
Last Post: Tilly37
  WARNING: Failed to get programme index feed for pointer2null. 1 3,116 12-06-2015, 07:03 PM
Last Post: pointer2null.