Atomicparsley gives "Exec format error" - not tagging m4a file
#1
Hi, I'm having problems with tagging the downloaded m4a.

Looks like an error with atomicparsley. The file isn't tagged after the normal download process, I've also tried the `--tag-only` option, but that doesn't work either.

Any help with troubleshooting would be appreciated.


get_iplayer Output:

bash-5.0# get_iplayer --pid=m000dphj --tag-only --tag-only-filename="Radio_1s_Residency-HAAi.m4a"
get_iplayer v3.23, Copyright (C) 2008-2010 Phil Lewis
  This program comes with ABSOLUTELY NO WARRANTY; for details use --warranty.
  This is free software, and you are welcome to redistribute it under certain
  conditions; use --conditions for details.


Episodes:
Radio 1's Residency - HAAi, BBC Radio 1, m000dphj
INFO: 1 total programmes

INFO: Processing radio: 'Radio 1's Residency - HAAi (m000dphj)'
INFO: Tagging M4A
open3: exec of AtomicParsley Radio_1s_Residency-HAAi.m4a --metaEnema --freefree --overWrite --stik Normal --advisory remove --copyright 2020 British Broadcasting Corporation, all rights reserved --title HAAi --artist BBC Radio 1 --albumArtist BBC Radio --album Radio 1's Residency --grouping Music,Mixes,Dance & Electronica --composer BBC iPlayer --genre Music --comment HAAi has a chat with Richie Hawtin and plays a trippy selection of downtempo chuggers. --year 2020-01-27T01:00:00Z --tracknum  --disk  --lyrics HAAi has a chat with Richie Hawtin and plays a trippy selection of downtempo chuggers.

PLAY: https://www.bbc.co.uk/programmes/m000dphj

INFO: https://www.bbc.co.uk/programmes/m000dphj --artwork ./Radio_1s_Residency-HAAi.jpg failed: Exec format error at /usr/local/bin/get_iplayer line 2131.
bash-5.0#
#2
A few suggestions:

You might want to read this first: https://forums.squarepenguin.co.uk/thread-706.html

Upgrade to the latest version of get-iplayer (you're one release behind, but I don't think this is your problem)

and:
$ AtomicParsley --version
If I recall correctly then you need at least version 0.9.6.

Does running AtomicParsley by hand on that file work?

Is the file corrupted in some way?

I downloaded that programme with --no-tag, and then tagged it successfully using the command line you provided. So I don't think there's anything wrong with get-iplayer itself here.

Just to set expectations... I'm away for a few days and probably won't be able to follow up until at least Friday - but others might be able to help.

Cheers
Jon
#3
Thanks for quick response.

I've tried with both 3.23 and 3.24 and get the same. I'm sticking with 3.23 at the moment as can't get high quality audio downloads with 3.24?

Trying `AtomicParsley --version` shows the problem....

Code:
bash-5.0# AtomicParsley --version
bash: /usr/local/bin/AtomicParsley: cannot execute binary file: Exec format error

I'm running this in a docker container - [based on this example](https://github.com/Marginal/docker-get_i...Dockerfile) - so there must be an issue with the AtomicParsley install rather than any problem with `get_iplayer`.