Windows 10 OS GIP version 3.23 0.0.0.0 not working fixed in 3.24
#1
Background to problem
I try and help a number of family members use get_iplayer on a variety of Windows, MacOs and Linux machines. The only ones that give me problems are Windows.
I try and keep a virtual machine of the previous and current versions of GIP to aid fault finding. Usually I ask anyone to ensure their OS is patched to latest version and GIP is the current version.

Host OS windows 10
version
10.0.17763 N/A Build 17763

get_iplayer version 3.23 doesn't seem to be accessible from other computers using the listen on 0.0.0.0 on the above build. tried turning firewall off internally - no difference.

Version
10.0.18363 N/A Build 18363 it worked remotely on 3.22

Linux OS 19.04 worked remotely on 3.23 and all other versions.
macOS 10.14 Mojave works remotely

Today I installed 3.24 on my test machine that wasn't working and remote now works again.

OK, this isn't really a problem anymore but I'd like to know why. I'm much more comfortable around Linux than MS Windows.

I suspect that Windows 10 seems to upgrade bits of the OS without asking and breaks other things (like start-up folder not executing, or even Scheduler not working properly) requiring workarounds.

Has anyone else had this (niche) problem?


Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED]  Where can I find a Windows XP/Vista-compatible version of ffmpeg? six-h 8 8,167 14-02-2019, 12:52 PM
Last Post: fredchan
  Can GiP be fixed? tvfan 2 3,288 13-03-2017, 09:03 PM
Last Post: tvfan