These forums are archived

See this post for further info

get_iplayer forums

Forum archived. Posting disabled.

RTMPDump swfurl error


I've recently installed get_iplayer on a laptop running Mint 17. I consistently get the following error from RTMPDump although radio programs then download successfully:

Quote:RTMPDump v2.4-n87-gita9f353c-ppa8~saucy
(c) 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
ERROR: RTMP_HashSWF: couldn't contact swfurl (HTTP error 302)
Connecting ...
INFO: Connected...
Starting download at: 0.000 kB

I've also tried one TV download which was successful but with a similar error.

My main downloader is installed on Ubuntu 14.04 on another machine and doesn't produce this error. Versions of get_iplayer and RTMPDump appear to be the same on both machines and come from Jon Davies' ppa.

Since downloads seem to work OK despite this error, I'm not too bothered about it but I'd like to know what's causing it. When the BBC changed the swfurl last year, downloads started to fail, so why don't my Mint downloads fail?

Any ideas?


The BBC changed that flash player URL to redirect to a new location, thus the "HTTP error 302". rtmpdump can't follow redirects. This is a different issue than what happened last year. You can download without a swf URL, but rtmpdump may then stop and restart numerous times, which may lead to download failure if it can't successfully resume download on each restart. I think that may only be true for video downloads.

This issue only affects users who installed from the PPA. The PPA build includes a post-2.86 update to the flash player URL, but the Beeb changed it to redirect only recently, after the PPA build was made. For the moment, use the Git HEAD version, where I've rolled back the flash player URL to its previous value:


Thanks for the reply user-2.

Rather than installing the Git Head version I added the swfurl contained in it to my options file using:

Quote:get_iplayer --prefs-add --rtmp-radio-opts="--swfVfy="

as you suggested last year and this seems to have done the trick.


Sorry that should be

get_iplayer --prefs-add --rtmp-radio-opts="--swfVfy="

These forums are archived

See this post for further info