mp3s cannot be played
#1
Hi,

I use get iplayer for radio and podcast programmes I am interested in.
Recently (since I have formatted my computer and reinstalled get iplayer) I have noticed the following issue: mp3s created by get iplayer cannot be played. E.g. "Composer of the Week" the m4a from the live radio show works fine, the mp3 from the podcast cannot.

I have tried different players (windows media player, media player classic, xbmc, itunes, android players) and installing a codec pack to no avail. This is a recent development as mp3s that were downloaded before the formatting worked and still work fine.

The broken mp3s are viewed as fine by mp3tag (i.e. it can read the tags such as author, title, etc), however they same tags are not read by windows explorer (working mp3s instead display the information also in windows explorer).
Most of the players mentioned above either ignore the file or after pressing play just do nothing.
Media player classic offers a little bit more insight:

<pre>
Code:
File Source (Async.)::Output
Media Type 0:
Unknown
AM_MEDIA_TYPE:
majortype: MEDIATYPE_Stream {E436EB83-524F-11CE-9F53-0020AF0BA770}
subtype: MEDIASUBTYPE_MPEG1Audio {E436EB87-524F-11CE-9F53-0020AF0BA770}
formattype: TIME_FORMAT_NONE {00000000-0000-0000-0000-000000000000}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 0
Media Type 1:
</pre>


Do not guarantee all the numbers above are correct but that's the type of error message I get.

Any help would be appreciated
#2
https://squarepenguin.co.uk/forums/topic...#post-2531
#3
Thank you!
That fixed it - brilliant. Thanks again