Cannot find encoding "cp720"?
#1
Hi guys,

I have just installed the latest version of the get_iplayer but I receive the following error message when I try to open it:

Cannot find encoding "cp720" at C:\Program Files (x86)\get_iplayer\get_iplayer.pl line 299.


I am using Windows 10.

Many thanks!
#2
Code page 720 (Arabic) not supported. Use chcp 850 to set command prompt to UK default before running get_iplayer. If 850 is invalid, try 1252.
#3
Hi there dinky,

Thanks, can you please tell me where (i.e. file name) I can set the command prompt to chcp 850?
#4
chcp 850 is the command to run. Google for clues on using chcp.
#5
Ah, I see.

When I write chcp - it shows: Active code page: 720
When I use the command chcp 850 - it shows: Active code page: 850
When I write chcp to double-check again - it shows: Active code page: 850

However, when I close the cmd.exe and start it again, the chcp shows 720 instead of 850.

It doesn't retain the new active console code page. Do you know why this might be?
My keyboard and country or region are set to United Kingdom (English) by default.

I'm trying to Google any solutions, I will post any solutions if I have found it.

Many thanks!
#6
chcp setting doesn't persist, and isn't supposed to. That's why I said run chcp before running get_iplayer. As to the rest, only you know what you have done to your machine. It's nothing to do with get_iplayer.
#7
Thanks, the error message has disappeared.
#8
For anyone encountering this issue: You need to figure out how your default console code page was changed. The most likely culprit is an incorrect system locale, which is separate from keyboard/region settings. If your system locale appears OK, you'll have to look at the other places your default console code page can be changed. Google is your friend here. Again, this has nothing to do with get_iplayer, so I'm closing this thread.