is the likely to be an Android APK in the making?
#1
The title says it all really.
Will there ever be, or indeed, is there, an Android APK of get_iplayer?
If not, it'd be interesting to know why. Or is it simply just because there's no one doing it?
Thanks in advance for all and any replies as it's something I've long puzzled over.
#2
I haven't tested this, but depending on what you're looking to do you might be interested in the Termux app and running get-iplayer from that.
#3
Termux? I'll do a search for it and see what it is. An emulator/virtual OS environment?
Thanks. Will go find out what ot is.
#4
(10-02-2019, 08:11 PM)weakice Wrote: I haven't tested this, but depending on what you're looking to do you might be interested in the Termux app and running get-iplayer from that.

Installed twenux which is runbing beautifully. However, when i ran pkg install get_player, it goes thru the motions (dependencies etc) then says get_iplayer not found. Tried searching (pkg search get_iplayer) then running install agaon. But no joy.
If anyone can suggest a command that'll helo success?
Thanks weekice tho, i thibk this apo will be very useful foe other things!
#5
So get_iplayer is in the termux repository, I wasn't expecting that!

I keep Termux installed because it seems like it should be incredibly useful, but I've never actually found something to use it for.

For finding where it's put the get_iplayer script you could try this:
Quote:Termux installs its packages in a folder exposed through the $PREFIX environment variable (with e.g. binaries in $PREFIX/bin, and configuration in $PREFIX/etc).

from here: https://wiki.termux.com/wiki/Differences_from_Linux

Or otherwise, now that the dependencies are installed, just wget the latest get_iplayer script into your home directory and run that?
#6
The latest wget? I'm really gonna have to do a refresher.
I no longer have my linux/ubuntu note book.
An example script would be lovely.
But thanks anyhow.
Will try proot thing.
Am wondering if i need to root the android, which means going thru all the crap root apps (without pc) to get it rooted?
#7
You shouldn't need root for Termux.

In Termux try this to download the get_iplayer script:
Code:
wget https://raw.githubusercontent.com/get-iplayer/get_iplayer/master/get_iplayer

might need to make it executable:
Code:
chmod +x ./get_iplayer

and then something like this to run it:
Code:
./get_iplayer
#8
Thanks for that, but result is: "can't execute 'perl': no such file or directory"
#9
Incidentally, i get a similar fail when i try to do the termux-ubuntu thing too.
#10
So far, nothing actually seem to be able to run on teemux further than initial scripts completing, and once apparently downloaded, unpacked and installed, it can't find anything!
So guessing as a non-expert, that termux filing system differs from the "norm"?

But nothing at all ever works on it, and certainly not getting get_iplayer to run.
#11
Yeah, sorry, I've just tried this myself and Termux doesn't make it easy. I got as far as Perl starting the get_iplayer script, but there are missing dependencies that don't install correctly.

Depending on what you're trying to do your next best option might be to run get_iplayer on a server somewhere and automatically sync the downloaded files to Android using an app like FolderSync or Syncthing.