These forums are archived

See this post for further info

get_iplayer forums

Forum archived. Posting disabled.

Can't download iplayer video content


Just started using get_iplayer (3.18.0) on macOS 10.12.6 Sierra. Installed using MacPorts and wget. I think...

I tried fetching a video using the video's code:

get_iplayer --get 2062

I tried using the pid:

get_iplayer --pid=b0c13qyn

I tried using the search method:

get_iplayer --get "Death in Paradise"

All attempts report this (or similar) error:

ERROR: Failed to download URL (3/3): (this URL changes with each video)
ERROR: Response: 500 Can't connect to
ERROR: Ignore this error if programme download is successful

and end with this:

WARNING: No media streams found for requested programme versions and recording modes.
WARNING: The programme may no longer be available - check the iPlayer site.
WARNING: The programme may only be available in an unsupported format (e.g., Flash) - check the iPlayer site.
WARNING: If you use a VPN/VPS/Smart DNS/web proxy, check with the provider to find out if it has been blocked.

I can ping successfully.

I can watch these videos in my web browser.

I've restarted the Mac.

I'm confident it's not a firewall issue because I can watch videos and ping

I'm not sure what next to try.


Thank you,

These forums are archived

See this post for further info