AtomicParsley cannot rename temp file to complete tagging
#1
Win 10
get_iplayer 3.16.0
DOS command line only
Radio rips only.

Hi,

Since the 31st July I've had no luck getting get_iplayer to produce mp3 files, I may have an idea what's the problem is.

(as per the docs) I use the --prefs option to produce mp3 files thus...

commandradio = ffmpeg -i "<filename>" -c:v copy -c:a libmp3lame -b:a 320k -id3v2_version 3 -write_id3v1 1 -y "<dir>/<fileprefix>.mp3" && del "<filename>"

...this is failing. I think the reason this is failing is because there isnt a valid m4a file for ffmpeg to process.
Here is an example of what m4a files are being produced when running get_iplayer at the moment...

'The Archers - 18674. 2018-08-03 b0bclyhz original.m4a' (0 KB)
'The Archers - 18674. 2018-08-03 b0bclyhz original-temp-8912.m4a' (30,733 KB)

I've tried independently running ffmpeg from the command line giving it the 'temp' file above (not the 0KB sized file). This works fine and gives me a mp3 file that I'd expect.

I'm guessing that in the above example get_player should produce just the one file thus...  

'The Archers - 18674. 2018-08-03 b0bclyhz original.m4a' (30,733 KB)

...for ffmpeg to have a valid file to process and everything to work as normal.

Any ideas how I can fix this?

Thanks.


Attached Files Thumbnail(s)
   
#2
Something on your system prevents AtomicParsley from renaming its temp file back to the original file name. One user has reported Google Music Manager as a cause. It also could be anti-virus interference or something similar. Only you know what you have done to your system. If you can't figure it out, just use the temp file as the source for transcoding. It will contain the metadata tags.
#3
Bingo! Thanks dinky.

The problem appears to be caused by 'McAfee BT Virus Protect', this is the free antivirus software that is available with a BT Broadband account.
Specifically the problem lies with 'Real-Time Scanning', turning this off, or disabling it for say 30mins fixes the problem and everything now works as before.

Since I've not messed with anything with my PC for a long while I can only assume the problem has occurred because of an auto-update to McAfee.
 
There is an option in 'Real-Time Scanning' to 'Exclude Files', I may have a tinker with this at some point, maybe.

Problem sorted!

Thanks again.


Possibly Related Threads...
Thread Author Replies Views Last Post
  How do I disable mp4 tagging? JBW 1 1,056 16-12-2017, 05:29 PM
Last Post: SquarePenguin
  Percent complete greater than 100% and "non-existing SPS 0 referenced" error pricespringer 6 2,938 10-07-2016, 10:41 PM
Last Post: I_love_subtitles
  AtomicParsley temp file sometimes left after download complete gezzao 2 1,936 26-08-2015, 05:00 PM
Last Post: gezzao
  Latest installer cannot install AtomicParsley moris 0 1,004 27-05-2014, 10:39 AM
Last Post: moris