How do I install modern version of ffmpeg (hint: read install docs)
#1
Just received a version error from ffmpeg (see below)

Do I just grab the latest ffmpeg & if so, where should it reside?

Code:
$ get-iplayer --nopurge --type=radio,tv "kate bush" --get --for --tvmode=better
get_iplayer 3.14-ppa32, Copyright (C) 2008-2010 Phil Lewis
 This program comes with ABSOLUTELY NO WARRANTY; for details use --warranty.
 This is free software, and you are welcome to redistribute it under certain
 conditions; use --conditions for details.


Matches:
3248: tv, Kate Bush at the BBC - -, BBC Four, b04f86xk
INFO: 1 matching programmes

WARNING: A UK TV licence is required to access BBC iPlayer TV content legally
INFO: Downloading tv: 'Kate Bush at the BBC - - (b04f86xk) [original]'
WARNING: Your version of ffmpeg (2.8) does not support conversion of dvf downloads to MP4 - not converting .m4a and .m4v files
WARNING: ffmpeg 3.0 or higher is required to convert dvf downloads to MP4
WARNING: Use --raw to bypass MP4 conversion and retain .m4a and .m4v files
WARNING: Use --ffmpeg-force to override checks and force MP4 conversion attempt
INFO: Downloaded: 42.59 MB (00:59:23) @ 12.62 Mb/s (dvfxsd1/ll) [audio]        
INFO: Downloaded: 713.90 MB (00:59:23) @ 32.09 Mb/s (dvfxsd1/ll) [video]
#2
Read the installation docs.
#3
Yep, that did the trick.

Thanks for the pointer - I thought because I'd used a package that it wouldn't be address in the core GIP documentation.


Possibly Related Threads...
Thread Author Replies Views Last Post
  How do I remove v3.00 manual install after upgrading from PPA on Linux Mint? karantula 2 849 17-07-2018, 01:58 PM
Last Post: jonhedgerows
  I didn't read the installation instructions, so I didn't know to install XML::LibXML epistemy 1 1,291 12-05-2017, 07:19 PM
Last Post: dinky
  Can only install v2.66 UKKid35 5 2,495 27-12-2015, 10:12 AM
Last Post: UKKid35