Need to change output directory
#1
Hi

I want to change the pout put directory for downloaded files. From the command line I have tried
--output "/c/directory/" but it says not a recognised internal or external command. I've looked through the guides but everything I've tried doesn't work

Thanks in advance

Tony
#2
You are on the Windows Forum so I assume your using Windows as your operating system.

In this section of the guide, it tells you how to use the
Code:
--output
command correctly. It also gives you a link to this page where it explains how to find the path to a folder on Windows.

The path you used in the example above is similar to what you might use on Linux, not Windows, and suggests you didn't read the guide/resources closely enough.
#3
Hi Square Penguin

Thanks for your quick reply, I am using windows and typing the output command from the command line, is this correct ?
#4
Show us the complete command you are running - we can't guess at it. Your error message has nothing to do with the output directory per se, so it's likely your mistake is somewhere else.
#5
C:\program files\get_iplayer> --output "/i/music getiplayer/"
#6
sorry I meant to type 2 dashes before the output command
#7
Are you trying to set a global preference for all downloads or simply specify an output location for individual downloads? Both are possible.

Firstly, know that
Code:
/i/music getiplayer/
will go to the root of your c: drive, i.e your main hard drive in the folder "i" inside which will be sub-folder "music getiplayer". If that's what you want, fine. But I suspect you may want it to go to the hard drive with letter "i:", in which case you need to get the correct path to the folder.

It could look like this for example, which is a command I use to save to my S: drive:

Code:
"S:\2 - TV Shows"

The link I gave you tells you how to easily copy the exact path to a particular folder, which you can then paste into the get_iplayer command line window. Read the info at the link I gave you.

Read it.

Secondly, you can use the
Code:
--output
command DURING each download to specify the download location like this example from the guide:

<pre>
Code:
get_iplayer --get "Top Gear" --tvmode=best --type=tv --channel="BBC Two" --file-prefix="<nameshort>-<senum>-<episodeshort>" --output "/media/TV Shows 1/2 - TV Shows/Top Gear/Season 19"
</pre>

Note the
Code:
--output
location at the end of the command.

Alternatively, you can specify a default download directory by saving a preference. Identify the folder you want downloads to go into and use the following command to save a preference:

Code:
get_iplayer --prefs-add --output="S:\2 - TV Shows"

You can get more advanced and have it set a preference to only save TV shows to this directory:

Code:
get_iplayer --prefs-add --outputtv="S:\2 - TV Shows"

You could even set a preference to only save TV shows to this location and have each show put into a sub folder based on the programme name

Code:
get_iplayer --prefs-add --outputtv="S:\2 - TV Shows" --subdir --subdir-format="<nameshort><-seriesnum>"

I don't use these options personally and have pulled them from the usage guide, so there might be one or two adjustments needed to get it to work perfectly.
#8
Two things here:

You've forgotten the most obvious part: the get_iplayer command itself. You can't use just the
Code:
--output
option without the get_iplayer command. And it makes no sense to run the get_iplayer command with just the
Code:
--output
option - it doesn't do anything.

Hopefully that previous paragraph is irrelevant because you are in fact actually trying to run a complete get_iplayer command. But when I said show us the complete command you are running, I meant exactly that: the complete command. And I told you that the error message has nothing to do with the output directory, yet you only provided the parameter for the output directory. We cannot guess what you are doing - you have to show us. Try again.

Beyond that, your output directory looks a bit suspicious. Do you really have a directory named "i" at the top level of your C: drive? You're using Windows, so specify directory paths in normal Windows format:
Code:
"C:\dir1\dir2"
. get_iplayer can cope with forward slashes, but it doesn't matter if the path is incorrect.
#9
Thanks guys, I've got it working now. I wanted to set the global download to a different drive and folder than the c drive and I can see where I was going wrong now, thanks for your prompt replies and advice

Cheers

Tony
#10
Hi
I wonder if you could tell me what is wrong with this command which I am using to change all output to a different directory. All I get is list of 1000+ programmes returned. I am a windows user and input the command lines directly. Files still download to the old default (desktop)

<blockquote>get_iplayer --output “C:\Users\Dell-Studio-Laptop\Music\archive\”


Thanks

Nick
#11
I should clarify that I am using a double hyphen before the command which has been auto corrected in the post to a long dash..
Nick
#12
Any command line option, including
Code:
--output
, will only apply to a single command invocation. Since you had nothing else on the command line, get_iplayer performed the default action: listing all available TV programmes. Presumably you want to make your new output location permanent. To do that, you need save it in your preferences with
Code:
--prefs-add
. See:

https://squarepenguin.co.uk/wiki/documen...g-settings

Select your command string and click the "code" button instead of "b-quote" to prevent WordPress from mangling it.
#13
Thanks dinkypumkin: with your help I set a new default directory. Two comments which I hope may be helpful:
1. I imagine many people will use one default directory (especially those who have swum here from the sad wreckage of Radio Downloader) so it might be worth flagging up both the global default and programme specific routes for changing directory in the help note.
2. If you make an error in changing directory, it is much quicker to change it by going to the 'output' file at \.get_iplayer (open with notepad) and changing the text there.
#14
walthamstownick: I might link to this thread or DP's specific answer in the guide if I see other struggling with this.
#15
Quote:<div class="d4p-bbp-quote-title">Dinky Pumpkin wrote:</div>Any command line option, including
Code:
--output
, will only apply to a single command invocation. Since you had nothing else on the command line, get_iplayer performed the default action: listing all available TV programmes. Presumably you want to make your new output location permanent. To do that, you need save it in your preferences with
Code:
--prefs-add
. See:

https://squarepenguin.co.uk/wiki/documen...g-settings

Select your command string and click the “code” button instead of “b-quote” to prevent WordPress from mangling it.

Many thanks for this post! I appreciate it.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Made a typo in output directory value - where did my file go? pwl2706 1 1,919 11-10-2018, 02:09 AM
Last Post: kamelne
  How do I change the get_iplayer output folder? betty77 3 4,343 28-09-2017, 01:02 PM
Last Post: ethereal
  Conversion to M4A performs poorly with output directory on slow network drive bobf 2 2,292 23-08-2017, 07:28 PM
Last Post: bobf
  Cannot Change output folder since 2.87 Update John Dalton 1 2,033 05-11-2014, 05:00 PM
Last Post: SquarePenguin