(Malwarebytes) Can't load 'C:/Program Files (x86)/get_iplayer/perl/.../IO.xs.dll'
I have been using this programme for a long time and it has always worked. Today it has stopped working completely. I have tried reinstalling it to fix it but it comes up with the same error.

Can't load 'C:/Program Files (x86)/get_iplayer/perl/lib/auto/IO/IO.xs.dll' for module IO: load_file:%1 is not a valid Win32 application at DynaLoader.pm line 193.
 at IO/Handle.pm line 269.
Compilation failed in require at IO/Handle.pm line 269.
BEGIN failed--compilation aborted at IO/Handle.pm line 269.
Compilation failed in require at IO/Seekable.pm line 101.
BEGIN failed--compilation aborted at IO/Seekable.pm line 101.
Compilation failed in require at C:\Program Files (x86)\get_iplayer\get_iplayer.pl line 52.
BEGIN failed--compilation aborted at C:\Program Files (x86)\get_iplayer\get_iplayer.pl line 52.


This comes up whatever I try and do and can't get it to do anything else.

Any idea what has gone wrong?
Same problem. Is malawarebytes causing the problem. How do I solve
Yes, Malwarebytes identified IO.xs.dll as containing "Trojan.Wdfload.Tsklnk".

I believe this to be a false positive (nothing else on virustotal reports a problem), but you have to make your own risk assessment.

Add "C:/Program Files (x86)/get_iplayer/perl/" as an excluded folder in Malwarebytes (initially I just excluded IO.xs.dll, but Malwarebytes then complained about another file - after a couple more attempts I got to this level and it worked).

You'll also need to restore the IO.xs.dll, or any other perl file that Malwarebytes has quarantined.

Once the false positive has been fixed by Malwarebytes you should probably take the exclusion out again. But to be honest, I don't know how you'll know without just trying it from time to time!

Hope that helps.
many thanks for that
Hi, I had a similar problem (slightly different wording) with Malwarebytes quarantining the same file. Checked on their forum Malwarebytes forum thread. Was a false positive and if you have Malwarebytes update package 1.0.5070 and above, should now be fixed.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Cannot connect to localhost:1935, Web PVR Manager wont load. OnTheBeeb 2 3,640 05-11-2018, 06:27 PM
Last Post: revdv
  XML::LibXML module doesn't load correctly under Git Bash meic 2 3,080 12-09-2017, 09:23 PM
Last Post: meic
  Get_iplayer does not download files saenbateman 14 13,839 05-04-2014, 11:20 PM
Last Post: dinky