Cannot find programmes from week of 19 March 2018 (Answer: rebuild cache)
#1
Hi,

I have been trying to download various programmes from between 21-25 but not all. I can find The Hitchicker's guide to the galaxy but not home front or Tommies. Tried used the pid and refreshing the cache. Using 3.13.0 and the web interface on windows 10. Any idea what is going wrong or a way around it?
#2
As you are clearly told in the release notes for 3.13 and in the documentation, the solution is to rebuild your cache. That is always the solution whenever recent programmes haven't been indexed and cached. Available programmes can always be downloaded with --pid or --url or via Quick URL in web pvr. You NEVER need to find programmes in search results in order to download.

This thread is closed. All me-too posts and duplicates will be deleted or dumped here.
#3
Could this be added to the FAQ? couldn't find out how to rebuild the cache for radio when searching the site. It might be obvious for people who undersands the get_iplayer interface but not to us who uses the web interface?
#4
For everyone else: A quick search for "rebuild cache" on this site or the documentation wiki will quickly lead you to the information you need. Or just put "get_iplayer" in front and ask Google. It was already in the FAQ list, but now it's there twice. And no, you can't do it in the web pvr, and you never will, as is true for a number of get_iplayer functions. If you are not willing to type commands at a prompt, you will have to live with those limitations.
#5
Just updated get_iplayer and run the web pvr, refreshed the cache and it wont show me anything other than what I got 19 days ago when I last used it? I've tried running just get_iplayer from command and forced a refresh and still nothing?
Any help would be greatly appreciated!
#6
I had the same issue. The command has changed since I used it last.

Now it requires a search term:

Code:
get_iplayer .*
lists all available programmes.
#7
So uninstalled, cleared out the get_iplayer folder and then reinstalled, also checked firewall which seemed to have started blocking cmd.exe, added an exception and then ran this command

get_iplayer Output:

get_iplayer --cache-rebuild --type=tv

And we're back in business!


Possibly Related Threads…
Thread Author Replies Views Last Post
  Cache rebuild restored missing programmes macerg 5 2,356 21-08-2019, 10:41 AM
Last Post: dinky
  [FIXED]  WARNING: Got 0 programmes... during cache refresh janus 4 2,757 19-08-2019, 09:09 PM
Last Post: dinky
  Is HD stream available for Top of the Pops Christmas 2018? andy29 2 1,960 29-12-2018, 03:44 PM
Last Post: andy29
  Can get_iplayer download Dynasties in 4K HDR? (Answer: No) yVfe 3 3,480 29-11-2018, 09:43 AM
Last Post: SquarePenguin