These forums are archived

See this post for further info

get_iplayer forums

Forum archived. Posting disabled.

Cannot find The Hitchhiker's Guide to the Galaxy with Web PVR search


I'm running the latest version of get_iPlayer on a Windows 10 system. For some reason, when I search for The Hitch-Hiker's Guide To The Galaxy (on BBC Radio), it doesn't find it. I've tried permutations of the hyphen and apostrophe and even just searching for "galaxy". With short enough search stribgs other shows appear in the result - but not Hitch-Hiker. Any suggestions?

All I can think of is - could the sneaky BBC be embedding nonprinting characters in the name so it's actually called something like "Hit[.]ch-Hi[.]ker Gu[.]de To The Gal[.]axy" where [.] is something which won't display?


When I first heard that HHGTTG was coming back I searched for it in the Web PVR manager without success.

However I just tried it, again in the Web PVR manager I found that all of:
- galaxy
- hitchhiker
- hitchhiker's

...returned search results.

Try the PVR manager.

If that does not work, how are you searching?


I'm searching in the Web PVR. I last tried last night, without success. Today is the day for episode 2 - if it's showing up now, it may be they refreshed their schedule tables (obviously they do that evey day, what I mean is "new version has HHGTTG in it")

I'm at work at the moment; I'll try at home again tonight.


The series pid is b09vm093, so that should work to fetch all episodes as they become available.


I just did a search on 'hitch' and it found episode 1.

Have you done a cache refresh recently?


Use 'Hitchhiker', not 'Hitch-hiker'. Caught me out, too.


Tried it when I got home last Thursday - worked as expected. I wonder if the first episode didn't make it into the first schedule? Ah well, working now!

Thanks everyone who tried variations.


There's even an extended version of Episode 1 that may be of interest:


managed to get the first 2 episodes but the 3rd episode is not showing up in search, it is on the iplayer site but can't get is tho show up in get_iplayer searches

OK searched for pid on command line and it workded, searching with web imterfave didn't find it


This is because the BBC have changed things. Dinky will be fixing it this weekend (I think)


These forums are archived

See this post for further info