Cache index > 1 day behind latest
I've noticed that since the start of this year, the Indexing of TV programmes is now over a day behind the latest entries on the iplayer website.
So I now have to wait over a day for them to appear in the cache to allow programme search by name
- or get PID from the iplayer website and use that manually (have to do this for news programmes, that only have 24hrs before they expire)

Have the BBC changed something on the iplayer webpages that has broke the scrape a bit?
- as it was working fine until the end of last year.

I was using GiP 3.06, but tried updating to 3.09 (and just now to 3.10) but still have the same issue.

EDIT: split from separate issue in original thread
I've just found what the problem was - The PC date had been accidentally set 1 day behind the current date!

(The PC Time had been reset OK, after completely turning off PSU so no permanent supply to keep clock running and CMOS battery was flat. But must have got date wrong when resetting and only have time displayed on taskbar, so hadn't noticed)

I do wonder if the --refresh-future (I'd subsequently tried after the cache rebuild issue) might still have allowed all the current programmes to have got added to the cache, despite the PC date being incorrect and I hadn't been aware of its impact on GiP cache building.