[SOLVED] (Homebrew) WARNING: Required ffmpeg utility not found - not converting .ts file(s)
#1
Hi,

I tried the the Homebrew crew and only gotten some head scratching. I'm now using my third OS for the HTPC as various machines have met their maker. This is the first time I've tried get_iplayer on a Mac.

The Homebrew instructions seemed simple and it installed with now errors on my OS X 10.13.2 macbook. I updated local commands and used the brew doctor to make sure I didn't have any other local weirdness.

While get_iplayer seems to not be able to call ffmpeg, I know it is working because I can use it in the terminal to convert all of the .ts files into .mp4.

My options file only has tvmode=best and the Movies folder in my user folder as output. I didn't mess with any other settings.

Any suggestions would be appreciated. I've got a post up on the Homebrew board as well.

Chris
#2
Try to bypass whatever is broken on your system by using --ffmpeg with the full path to ffmpeg. If it doesn't work, follow our instructions to provide a proper report so we can see what is happening on your system. If it does work, add it to your preferences and remove it later if you figure out what is broken. On that subject, "tvmode=best" is an invalid options file entry. The "=" should be a space. You should delete that entry anyway since it is the default setting.
#3
Thanks Dinky,

1. As I stated before, but less clearly, the error I was getting was from the Web_PVR (also 3.07 Homebrew). I was also running get_iplayer -pvr as a cron job and all of the media files created that way were also being created with the .ts extension.

2. The response from get_iplayer-V is:
get_iplayer 3.07-homebrew, Copyright (C) 2008-2010 Phil Lewis

3. I am running OS X 10.13.2 on a 2015 macbook pro

4. I was using the Web_PVR when I got the error message (in the subject line).

5. Using the --ffmpeg option eliminates the error in the Web_PVR and command line.

6. I've removed the tvmode = best

Everything seems to be working smoothly now. I'll check in with the homebrew folks to see if the can help me diagnose why the build isn't pointing at ffmpeg. I'll try a clean install on another machine that is on the OS and see if I get the same error.

Thanks
#4
To avoid --ffmpeg ffmpeg must be in $PATH. That is the place to start.


Possibly Related Threads...
Thread Author Replies Views Last Post
  [INVALID]  Homebrew ffmpeg - dyld: Library not loaded: /usr/local/opt/jack/lib/libjack.0.dylib hrh 3 2,196 11-02-2018, 01:36 AM
Last Post: dinky