Mojolicious dependencies not installed with cpan utility on Debian wheezy
#1
Hi, I have installed Mojolicious with command
Code:
cpan Mojolicious
, and it's up to date (7.46)but it still warned me to install Mojolicious and reverted to sequential indexing.
#2
Identify your OS and version, and post the output from:
Code:
perl -V
Also post the output (if any) from:
Code:
perl -MMojo::UserAgent -e 'print $INC{"Mojo/UserAgent.pm"},"\n"'
#3
Code:
root@Debian7:~# cpan Mojolicious
Going to read '/root/.cpan/Metadata'
 Database was generated on Sun, 01 Oct 2017 22:17:02 GMT
Mojolicious is up to date (7.46).

Code:
root@Debian7:~# perl -V
Summary of my perl5 (revision 5 version 14 subversion 2) configuration:
 
 Platform:
   osname=linux, osvers=4.9.0-2-amd64, archname=x86_64-linux-gnu-thread-multi
   uname='linux tatooine 4.9.0-2-amd64 #1 smp debian 4.9.13-1 (2017-02-27) x86_64 gnulinux '
   config_args='-Dusethreads -Duselargefiles -Dccflags=-DDEBIAN -D_FORTIFY_SOURCE=2 -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Dldflags= -Wl,-z,relro -Dlddlflags=-shared -Wl,-z,relro -Dcccdlflags=-fPIC -Darchname=x86_64-linux-gnu -Dprefix=/usr -Dprivlib=/usr/share/perl/5.14 -Darchlib=/usr/lib/perl/5.14 -Dvendorprefix=/usr -Dvendorlib=/usr/share/perl5 -Dvendorarch=/usr/lib/perl5 -Dsiteprefix=/usr/local -Dsitelib=/usr/local/share/perl/5.14.2 -Dsitearch=/usr/local/lib/perl/5.14.2 -Dman1dir=/usr/share/man/man1 -Dman3dir=/usr/share/man/man3 -Dsiteman1dir=/usr/local/man/man1 -Dsiteman3dir=/usr/local/man/man3 -Dusesitecustomize -Duse64bitint -Dman1ext=1 -Dman3ext=3perl -Dpager=/usr/bin/sensible-pager -Uafs -Ud_csh -Ud_ualarm -Uusesfio -Uusenm -Ui_libutil -DDEBUGGING=-g -Doptimize=-O2 -Duseshrplib -Dlibperl=libperl.so.5.14.2 -des'
   hint=recommended, useposix=true, d_sigaction=define
   useithreads=define, usemultiplicity=define
   useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
   use64bitint=define, use64bitall=define, uselongdouble=undef
   usemymalloc=n, bincompat5005=undef

Code:
root@Debian7:~# perl -MMojo::UserAgent -e 'print $INC{"Mojo/UserAgent.pm"},"\n"'
Can't locate IO/Socket/IP.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/local/share/perl/5.14.2/Mojo/IOLoop/Client.pm line 5.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.14.2/Mojo/IOLoop/Client.pm line 5.
Compilation failed in require at /usr/local/share/perl/5.14.2/Mojo/IOLoop.pm line 7.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.14.2/Mojo/IOLoop.pm line 7.
Compilation failed in require at /usr/local/share/perl/5.14.2/Mojo/UserAgent.pm line 6.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.14.2/Mojo/UserAgent.pm line 6.
Compilation failed in require.
BEGIN failed--compilation aborted.
#4
Thanks. The error message tells you what is wrong. You are missing the IO::Socket::IP module, required by Mojolicious.
#5
Thanks, it's fine now! I googled a lot and installed IO::Socket::IP. And Socket module is also required. Now everything works good. Concordance indexing is quite faster!


Possibly Related Threads...
Thread Author Replies Views Last Post
  Cache not updating from custom web UI on Debian asprinwizard 12 4,373 03-11-2017, 04:17 PM
Last Post: asprinwizard
  Cache not updating on Debian jlc 11 5,385 31-10-2017, 02:56 PM
Last Post: jlc
  Cannot download schedule pages to update cache on Debian Wheezy pippolippi 3 3,503 26-10-2017, 05:03 PM
Last Post: xiatian
  Debian Stretch crashes while running get_iplayer with NFS adhawkins 8 3,650 06-08-2017, 08:07 PM
Last Post: adhawkins