Getting "ERROR: Programe Type 'b095fqgy' does not exist" for all downloads
#1
Since about 11am on Thursday 28 September, whenever I try to download a programme I get the following message:
ERROR: Programe (sic) Type 'b095fqgy' does not exist
I also get this message when opening a new get_iplayer window.
I have restarted my computer, and reinstalled get_iplayer (version 3.02). The error persists.
Is this a problem with my computer, or yet another attempt by the BBC to block usage of get_iplayer?
(For information, b095fqgy appears to be the PID for the BBC News programme on 18 September. I have never tried to download this programme, and indeed never been near it.)
#2
Only a limited number of news programmes are available, such as News at One, Six and Ten on BBC One. But even then they are only available for 24 hours. I haven't checked the PID but if it's from 18th September, that's why you can't download it.

A good test if you're getting this result is to go to the BBC iPlayer and see if you can watch it there. If you can't, then you certainly won't be able to download it on get_iplayer.

Hope that helps.

HV
#3
I'm afraid I didn't explain myself very well. The message:
ERROR: Programe Type 'b095fqgy' does not exist
is a message which intrudes itself all the time, no matter what PID I am trying to access. get_iplayer then won't access the PID which I do wish to download, but grinds to a halt.
My question doesn't really have anything to do with b095fqgy in itself, or with my trying to download it (I don't wish to), but with the fact that the message about b095fqgy, which appeared out of nowhere, stops get_iplayer from working.
#4
Your preferences are likely mangled. Post the output from get_iplayer --prefs-show
#5
Output is:
Options in 'C:\Users\Roger/.get_iplayer/options'
output = C:\get_iplayer_recordings

I can't access the file in C:\Users\Roger/.get_iplayer/options; however, the file is only 1KB large.
Hope this helps (though I can't quite see how it would).
#6
Not in your options file then. Somehow you are specifying the equivalent of --type=b095fqgy, which is invalid. The other possibility is that you have somehow embedded it in PVR searches. Use get_iplayer --pvr-list to check. If that doesn't shed any light, follow our instructions to provide a full report so we can see what is happening on your system.
#7
Thanks. Here is my support request.
My problem is that I get a message:
ERROR: Programe Type 'b095fqgy' does not exist
every time I try to download something; get_iplayer then halts; the PID b095fqgy is the same every time.

I am using get_iplayer version 3.02. My operating system is Windows 7, Home Premium, Service Pack 1.
An example of my download attempt would be:
get_iplayer --type=tv --modes=good --pid=b096slhz
The problem appears no matter what PID I use.
I am attaching the log.txt file.

Hope you can help!

.txt   log.txt (Size: 1.09 KB / Downloads: 79)
#8
Thanks. No answers there, unfortunately. It's a long shot, but take a look at the contents of C:\Users\Roger\.get_iplayer\options to see if something is in there that wasn't printed in the output. You said before that you couldn't access that file, but if that were true, get_iplayer couldn't read it either, so take another look. For good measure, look at C:\ProgramData\get_iplayer\options as well. That directory and file should not exist in recent releases of get_iplayer, but check to make sure.
#9
I have managed to have a look at my options file. It simply gives my output directory. I don't have any file in c:\ProgramData\get_iplayer\options.
I'm very happy to reinstall get_iplayer, but I have in fact already done this! Is there anything I should do to ensure that the new version COMPLETELY overwrites the old version?
Otherwise, does it look like I'm completely stuck? (If dinky can't help, what hope is there for mere mortals?)
#10
The "b095fqgy" is coming from somewhere, but it will be a mutual waste of time to engage in more remote debugging. Time to slash and burn:

Uninstall get_iplayer, delete C:\Program Files\get_iplayer or C:\Program Files (x86)\get_iplayer as appropriate, delete C:\Users\Roger\.get_iplayer and C:\ProgramData\get_iplayer (if it exists), and perform step #2 here:

https://github.com/get-iplayer/get_iplay...ki/cleanup

then delete any remaining Start Menu shortcuts for get_iplayer, including those you have pinned yourself.

Reinstall get_iplayer and reset your output directory:
Code:
get_iplayer --prefs-add --output=C:\get_iplayer_recordings
then rebuild your cache:
Code:
get_iplayer --cache-rebuild --type=tv,radio
Change --type as required.
#11
Hello. Sorry for the delay in replying. I received your message late, so decided to reinstall get_iplayer the following day. But the following morning I found that rebooting had completely solved my problem, and the rogue message about b095fqgy had disappeared. However, I had already closed down my PC and rebooted, as the first step when the problem arose. Is there any circumstance whereby you need to reboot twice, before a problem disappears? The question is intriguing me. But my problem has been resolved, so I don't need to worry further. Thanks again for your help in guiding me through a perplexing problem. I have copied out the reinstall instructions, in case I need them in the future.


Possibly Related Threads...
Thread Author Replies Views Last Post
  ERROR: Programme type '' does not exist 12stringbassist 10 5,662 10-11-2017, 01:57 PM
Last Post: 12stringbassist