Raspbian Stretch signature verification issue with repository
#1
Good morning,

I recently upgraded my Raspbian install to Stretch and Get_Iplayer 3.01 works fine.
I noticed that 3.02 has been released so ran sudo apt-get update, but there is an error with the signature verification.

It appears that the http://packages.hedgerows.org.uk/raspbian/jessie/ repository still contains 3.01 at this time as it happens!

It's worth noting that there isn;t currently a repo for stretch on this site so I've left it pointing at the Jessie repo.

Anyway, here's the error if anyone can help!:

Hit:7 https://dl.bintray.com/mpmc/deb raspbianjessie Release
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://packages.hedgerows.org.uk/raspbian jessie/ Release: The following signatures were invalid: 4C5653EB93401EAECAF6B28E8B07C4FF0F5BFDFE
W: Failed to fetch http://packages.hedgerows.org.uk/raspbia...elease.gpg  The following signatures were invalid: 4C5653EB93401EAECAF6B28E8B07C4FF0F5BFDFE
W: Some index files failed to download. They have been ignored, or old ones used instead.
#2
You're right that packages.hedgerows.org.uk still has 3.01, and is still serving packages for jessie (though as you note they work fine on stretch anyway). I'm in the process of upgrading my pi to stretch, and once that's done I'll build a fresh version of the repository for stretch, together with gip 3.02.

Expect it to take a few days ;-)

Jon
#3
Cheers Jon!
#4
Hi Jon,
I get this error when doing apt-get-update:

Get:1 http://packages.hedgerows.org.uk jessie/ Release.gpg [72 B]
Get:2 http://packages.hedgerows.org.uk jessie/ Release [1,571 B]
Err http://packages.hedgerows.org.uk jessie/ Release
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://packages.hedgerows.org.uk jessie/ Release: The following signatures were invalid: BADSIG 8B07C4FF0F5BFDFE Jon Davies <jon@hedgerows.org.uk>

W: Failed to fetch http://packages.hedgerows.org.uk/raspbia...ie/Release

W: Some index files failed to download. They have been ignored, or old ones used instead.


I have no intention of upgrading to stretch and run GIP 302 on Jessie, will I stop getting the update error when you upgrade your Pi?

TIA
Steve
#5
For those who insist on continuing to use an unsupported operating system... (aka raspbian Jessie)

Please switch to the "stable" repository, following the instructions (for stretch) on http://packages.hedgerows.org.uk

this should work today if you've previously installed gip using the old jessie repository, but won't work yet for a fresh install of jessie. I'll rebuild ffmpeg targeted at "stable" rather than "jessie", but it takes about a day to build on my raspberry pi 1 so please don't hold your breath.

Jon


Possibly Related Threads...
Thread Author Replies Views Last Post
  Debian Stretch crashes while running get_iplayer with NFS adhawkins 8 3,650 06-08-2017, 08:07 PM
Last Post: adhawkins
  Raspbian : The following signatures were invalid during apt-get update sheddyian 2 1,958 19-05-2014, 04:56 PM
Last Post: sheddyian