Web PVR: "Unable to create server socket: Permission denied" error on startup
Hello there,

I'm running Windows 10 Pro and I keep it up to date.

I'm running the latest version of get_iplayer 3.01.0.

I've been using get_iplayer for a long time without any problems at all but today the Web PVR Manager wouldn't open in any browser. I get...

"This site cannot be reached. localhost refused to connect"



I've checked for a problem with my internet connection but there isn't one.

I tried reinstalling get_iplayer but this hasn't solved the problem.

Looking at the get_iplayer cli I get the following...

Unable to create server socket: Permission denied at C:\Program Files (x86)\get_iplayer\get_iplayer.cgi line 272

I'm a novice with cgi scripts so can't work out why this has suddenly started to happen.

I'm not using a VPN and I'm in the UK.

Any help would be much appreciated.

A possible culprit is a third-party antivirus/firewall. You may need to explicitly exempt the Perl interpreter (C:\Program Files (x86)\get_iplayer\perl\perl.exe) from whatever restrictions prevent it from opening a network socket. You would have to figure out how to do that for your particular antivirus/firewall.
Hi there,

Thanks for your quick reply.

I use Bitdefender and have just checked the firewall rules.

Sadly, perl.exe already has a rule - bi-directional - any network - allow.

I've attached a .jpg of the browser page, the PVR cli output and the firewall rules.

It's quite bizarre as I was having no issues until yesterday.

Am wondering if it's a Windows 10 update that's to blame?



Attached Files Thumbnail(s)
The browser error is irrelevant. It just reflects the fact that the Web PVR server couldn't launch. If you didn't add the firewall rule for perl.exe, you might check that it applies to the perl.exe installed with get_iplayer (unless it is supposed to apply to any perl.exe). The next logical step is to completely disable Bitdefender (including any system services it launches) and attempt to run the Web PVR again.
Hello again,

I did all of the things you suggested but nothing solved the problem until I completely removed get_iplayer from my system using a smart uninstaller and then did a fresh reinstall from scratch.

It's now working again. Still a bit bizarre that this happened. After disabling the bitdefender firewall, making sure the windows firewall was off get_iplayer would still refuse to work.

Anyway, all is well now.

Thanks very much for your help Dinky.

Good news. "Permission denied" is a pretty generic error that might mean any number of things. One of the hazards of providing Perl with get_iplayer is that a bad install can lead to cryptic system errors like that. Delete and reinstall is never a bad idea in that case.
I know this is an old thread, but I thought I would add a proper explanation for this error message.

It is a port conflict caused by another piece of software using port number 1935 when Web PVR Manager starts and tries to use it.

When I had this error message, I used the following command (on the Windows Command Prompt) to find the background process/program causing the problem.

netstat -n -a -o | find "1935"

 TCP              LISTENING       2300

The last number (2300 in this example) is the process ID (PID).

Now open Task Manager and go to the Details tab and find the number in the PID column (click the column heading first to sort in numerical order).

Now you will have the name software causing the problem - a backup program in my case.  If the program is part of a service, as was with me, then find the relevant server in the Servers tab on Task Manager and stop it.

If you repeat the netstat command, you shouldn't see any output now and Web PVR Manager should run fine.

Sometimes, just rebooting the PC will fix this as the offending program may be using a random port and just happened to choose 1935 after the last restart.  If it doesn't then it may mean that you have installed some new software that also wants to use port 1935.  Now you have to figure out how to change the port number for that program or get_iplayer so they don't conflict.

I haven't looked up the commands for Linux, but the principle is the same.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to create server socket: Permission denied colinp 3 2,331 16-06-2019, 10:00 PM
Last Post: mrg9999
  Access Denied error on Windows texx 2 3,838 01-07-2018, 10:37 PM
Last Post: texx
  Could not create default output directory after reinstall Koyangi 9 9,236 03-09-2016, 11:44 AM
Last Post: Koyangi
  Can't create file that already exists alanem 6 5,838 16-10-2015, 07:24 PM
Last Post: alanem