Unable to install v3.01.0 on Windows 10 (prevented by Comodo)
#1
I have been trying to install the latest version of get_iplayer, Version 3.01.0 but I have been unable to. I was previously using Version 2.94 but was unable to download a recent programme from BBC iPlayer so I thought I would upgrade to see if that helped.

In trying to install the latest version I removed 2.94 but can still not install 3.01, and now I can't even re-install 2.94 so at the moment I have nothing to use.

The PID of the programme I was trying to download is p0559fd8 but I have no idea why it wouldn't work. Can anyone please help me get a working version of get_iplayer installed on my computer and possibly tell me why that programme will not download? By the way I am using Windows 10 Home 64-bit if that makes any difference.

Thank you
#2
I am presently running 3.0.1 on windows 10 x64 , downloaded from https://github.com/get-iplayer/get_iplay...3.01.0.exe

what error do you get when you try to install it?
#3
Thanks for your prompt reply.

First of all I have managed to get version 2.94 working again so at least I have something to use.

When trying to install the latest version I don't get any errors, it appears to complete the installation but afterwards nothing happens. When I launch get_iplayer from the start menu it runs the previously installed version (2.94) so it doesn't seem to be updating the files properly when installing.

And when I run version 2.94 and try to download the programme I want I still get an error, I have attached a screenshot of the problem


Attached Files Thumbnail(s)
   
#4
Is nobody able to help at all?
#5
You gave no indication as to why you think you can't install v3.01.0. You only actually demonstrated that you couldn't invoke it from a menu shortcut installed with v2.94. The installer tries to clean up old versions, but there are reasons that might fail. It would be a mutual waste of time trying to figure out which one applies in this case. Support for v2.94 was dropped a year ago, and the BBC has rendered it useless in the interim. The first thing you need to do is eradicate it from your machine. Run the uninstaller, delete C:\Program Files (x86)\get_player (and wherever you installed v2.94, if different), then follow the cleanup instructions here: https://github.com/get-iplayer/get_iplay...ki/cleanup. Also delete any get_iplayer shortcuts you created yourself.  Then run the v3.01.0 installer. If there is no C:\Program Files (x86)\get_player directory created by the installer, then there is something on your system (anti-virus?) preventing the installation.
#6
Thank you for your reply.

I did wonder if the problem with downloading was due to version 2.94. I will give uninstalling a go again and see what happens
#7
I am seeing exactly the same issue on my windows 10 64bit pc

The new install of 3.01 does not overwrite 2.94 / 2.97 at all and but the install file seems to complete properly.

Upon removing 2.94 and trying a re-install, the install program again seem to run properly , however again nothing actually seems to be created.

No folder is created in program files x86, no start menu, no program in control panel to uninstall etc.

I plan to now try going back one version at a time to see when the install starts to work.
#8
That sounds very much like the problem I am having.

I am going to follow the instructions provided by dinky to see if I get it working
#9
Fixed......

Just as suggested above, i had a silent AV issue with Comodo internet security premium which i have now uninstalled as it has messed me about far too often and was already past its last warning.

Once removed fully get-iplayer installed without issue.

Keep up the great work guys
#10
I use Comodo as well, maybe that is the problem for me also
#11
So I uninstalled version 2.94 and then removed everything mentioned in that cleanup document.

I closed Comodo completely so it wasn't running at all and then tried installing version 3.01 but the problem remains, the installer appears to finish but nothing is created.

Not sure what else I can do :(
#12
Comodo is a pain. You either will have to somehow whitelist the file as an install file or better still get rid of comodo like i did.

It is a pain in the A$$ like this, fails to play video files in chromodo, geek buddy is little more than junk etc.

Malwarebytes is ok though.
#13
Just decided to do a search on the C: Drive for files relating to get_iplayer and it found some files in a hidden folder called C:\VTRoot but I have no idea what this folder is for.

The cleanup document doesn't mention this folder so I'm not sure whether to try deleting the files I found in there or not
#14
I deleted them but again, it made no difference :(
#15
Uninstall Comodo - you know i am right :)

You could even re-install it again afterwards if you really feel lost without it.

As you might guess, i will not be re-installing it.
#16
Actually I really like Comodo lol!

But I sorted it. Even though I closed Comodo there were still a couple of processes running in Task Manager so I clicked the End Task button on those as well and then I was able to install version 3.01 without any issues!

And I am now downloading the programme I wanted, hopefully it will complete without any issues now

Thanks to everyone who helped!
#17
C:\VTRoot is the Comodo sandbox.
#18
Thanks for the information John, very useful!


Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to install 3.20.0: "side by side configuration is incorrect" system error Veerod 1 2,863 22-03-2019, 08:18 AM
Last Post: dinky
  Anti-virus prevented get_iplayer installation sandking072 7 7,608 17-11-2017, 01:42 PM
Last Post: SquarePenguin
  Unable to download Windows version 747skipper 3 3,953 28-02-2017, 11:50 PM
Last Post: 747skipper
  Windows install question bww 2 2,739 31-12-2013, 08:39 PM
Last Post: bww