Empty subtitles with V3
#1
I've just upgraded to V3, previous one had of course stopped working with whatever changes the BBC have made. Had to add the program directory and that for the utils and perl to the beginning of the path to get everything working.

If I use either the new default for subtitle handling or the mono or raw option then the download fails with odd parsing errors, I've added the option 
Code:
get_iplayer --prefs-add --subsfmt=default

to put the processing back to the older method, however, although the video downloads now I get an empty subtitle file.

Example output

get_iplayer Output:

Matches:
7818: Timeshift: Series 16 - Penny Blacks and Twopenny Blues: How Britain Got Stuck on Stamps, BBC Four, b082v57b

INFO: 1 Matching Programmes
INFO: Checking existence of original version
INFO: hlshd1,hvfxsd1,hvfxsd2,hvfxsd3,hvfxsd4,hvfxsd5,hvfxsd6,hvfxsd7,hvfxsd8,hvfxsd9,dvfxsd1,dvfxsd2,hlsvhigh1,hvfxhigh1,hvfxhigh2,hvfxhigh3,dvfxhigh1,dvfxhigh2,hlsstd1,hlsxstd1,hvflow1,hvflow2,hvflow3,dvflow1,dvflow2 modes will be tried for version original
INFO: Trying hlshd1 mode to record tv: Timeshift: Series 16 - 3. Penny Blacks and Twopenny Blues: How Britain Got Stuck on Stamps
INFO: File name prefix = Timeshift_Series_16_-_3._Penny_Blacks_and_Twopenny_Blues_How_Britain_Got_Stuck_on_Stamps_b082v57b_original                

INFO: Downloading subtitles to: D:\Users\Ian\Desktop\iPlayer Recordings/Timeshift_Series_16_-_3._Penny_Blacks_and_Twopenny_Blues_How_Britain_Got_Stuck_on_Stamps_b082v57b_original.srt
WARNING: Subtitles empty
INFO: Begin recording file: D:\Users\Ian\Desktop\iPlayer Recordings\Timeshift_Series_16_-_3._Penny_Blacks_and_Twopenny_Blues_How_Britain_Got_Stuck_on_Stamps_b082v57b_original.video.ts
INFO: Begin recording at: 0.00 MiB (00:00:00) [1]
It's so far on both programs I've fetched both via CLI and web interface.

FWIW I also have a warning about pocdcast but there's no podcast specified in my PVR list. There was one but I've deleted it. Both restarted the PC and removed and reinstalled get_iplayer but no difference seen.

-- 
Ian
#2
Your example works fine here. Probably a temporary upstream glitch. If not, follow our instructions to provide a full report so we can see what is happening on your system.
#3
I downloaded a previous Horizon episode with the command
Code:
get_iplayer>get_iplayer --pid=b05n8jqs --subtitles --metadata=xbmc_movie --force --verbose > D:\temp\log.txt 2>&1

Same as before the SRT file is empty, the video has saved. I have this program already once with subtitles so it did work in the previous version. Link to compressed log  sorry in all it's about 15MB can't attach the compressed file directly.

-- 
Ian
#4
You are apparently not using the Windows installation I provide, so I'm afraid I can't offer any support. You're definitely not using the provided version of ffmpeg, and I suspect you have overlaid the get_iplayer script onto an old Perl distribution with broken or missing HTTPS support. Moreover, you appear to be using get_iplayer outside the UK. Thread closed - see forum rules.


Possibly Related Threads…
Thread Author Replies Views Last Post
Bug [FIXED]  Web PVR: Recordings tab empty with "Force Recording" = on magic144 4 3,909 05-10-2017, 02:45 AM
Last Post: magic144