These forums are archived

See this post for further info

get_iplayer forums

Forum archived. Posting disabled.

V3.00 - Required ffmpeg utility not found - not converting .ts file



First of all thanks for getting get_iplayer fixed.

I mostly tend to run get_iplayer from the command line. I just tried the new version, and I'm getting this error message:

WARNING: Required ffmpeg utility not found - not converting .ts file

I'm not getting it when I'm running it from the web manager, so clearly there must be an option out of place or something like that.

Could you enlighten me on what this warning is referring to and what I could do to fix it?



Post the output from get_iplayer --show-prefs


Thanks, but there's nothing there.

In the meantime, I found the problem by having a look at the source code. It seems ffmpeg needs to be in the get_iplayer directory, or in a directory contained in path. And it wasn't. I moved it one up from the directory called utils, and that fixed it.

Still strange that the web manager didn't complain about it.


I was going to say that I don't know about the Web Manager but for the CLI, that message for ffmpeg (fast forward mpeg) that it is either not in the same directory as the main GIP program or the directory where it is expected if GIP was installed using the Windows installer or it's not in the PATH & that's why it cannot be found.

With the Windows installer for GIP I can't remember where it puts ffmpeg but I think on my Windows 8.1 64bit laptop it was either in the bin or utils directory e.g.

C:\Program Files (x86)\get_iplayer\bin
C:\Program Files (x86)\get_iplayer\utils

But it's not there for me no more because I've moved it & I've also put it in the PATH only recently & I've never added anything to the Windows PATH before.

I've created a directory called ffmpeg & this is where it lives now.


Within this directory I have 3 programs, ffmpeg, ffplay & ffprobe.

Now that I've added ";C:\ffmpeg\bin" to the PATH, then any of those 3 programs can be started at any point in a CLI whereas if the ffmpeg or the other 2 programs were not in the PATH but were just in the get_iplayer directory then they could only be invoked from the CLI where the get_iplayer is invoked.

It's possible that DINKY would advise against moving ffmpeg from where it is installed when using the Windows installer but if not, or if anybody wants to know how to install ffmpeg & how to put it in the PATH, then this link is quite useful & will give you instructions with pictures of how to do it.

By the way, the latest ffmpeg stable static version is 3.3 & can be got from this link,
Other builds for Linux, OS etc I believe you can also get from this site.

A tip I saw somewhere on the Net. When you add something to the PATH always start with a semi-colon, e.g. ; before you put anything else but the end of the last entry in the PATH there is no semi-colon at the end.


It is likely that your system PATH environment variable is corrupt or broken, so when it's altered locally in the get_iplayer batch file you just wind up with a longer broken PATH. This has happened to other users and is often caused by a badly-behaved installer from some other application. It is noted in the Windows install doc. However, since you know how to work around it I won't waste my time or yours investigating further. Whatever is wrong with PATH would be unique to your machine, so there isn't any real help I could give anyway.


For clarity's sake, where are executables supposed to reside, and what is supposed to be added to the PATH for get_iplayer to work correctly?

I had ffmpeg.exe in \get_iplayer\utils, and my PATH did contain \Program Files (x86)\get_iplayer, but not the utils directory. Is that how it was supposed to have been?


C:\Program Files (x86)\get_iplayer is appended to system PATH by the installer. That is necessary to run get_iplayer from a normal command prompt. ffmpeg.exe is supposed to reside in C:\Program Files (x86)\get_iplayer\utils, which is prepended to PATH at runtime. It is done this way to guarantee that get_iplayer uses the expected ffmpeg.exe. It is also done this way so it won't interfere with another ffmpeg that may be installed after get_iplayer. Not likely for most users, but a useful courtesy. If problems with system PATH become more prevalent I might change things, but this doesn't happen too often.



I have had this same problem since the new version came out, so I believe it's not a one off thing. I ran the old iplayer on win xp with no problems, the files immediately converted to m4a using the ffmpeg on the system and it was pretty fast. I use it on BBC radio programmes, and using the cmd line get_iplayer --pid=xxx --type=radio fetched me the programme in a m4a file quickly.

With the latest version, i get the same error as above. I installed as per usual, on the very same machine. If it (the ffmpeg) worked previously, then shouldnt it work now?

So with this error instead of getting a m4a file like before I am getting a ts file about 10 times the size it used to be.

I checked my iplayer folder, the ffmpeg file is there as it should be. (ie C:\Program Files\get_iplayer\utils

Somehow the programme isnt able to use it.

hope u can advise, or fix it?

anyway thanks for the good job getting it up and running again after the previous stumbling block by BBC ;)

These forums are archived

See this post for further info