ERROR: RTMP_ReadPacket, failed to read RTMP packet body
#1
I'm using get_iplayer 2.83-1 on Debian Stable 7 (Wheezy). I've recently upgraded from the patched 2.82 in Debian's repos in an effort to solve the problem but that hasn't worked.

After a long while of trouble-free use, in the past couple of weeks I've started getting a load of errors and failures with get_iplayer. Radio programmes download with no problems, but TV is patchy to say the least. Error messages vary:

<pre>
Code:
ERROR: RTMP_ReadPacket, failed to read RTMP packet body. len: [followed by a number]
WARNING: HandleInvoke, Sanity failed. no string method in invoke packet

ERROR: DECODING ERROR, IGNORING BYTES UNTIL NEXT KNOWN PATTERN!
ERROR: HandleInvoke, error decoding invoke packet
WARNING: Received FLV packet before play()! Ignoring.
</pre>


Sometimes there isn't an error, but instead the percentage download progress status goes crazy and quickly ends up with a crazy percentage such as 1650 % and stops there until I have to ^C the process.

I try manually selecting modes and sometimes this works and produces a successful download but there seems to be no consistency to this. If I choose, say, flashstd1 for one TV programme it could download successfully, but on the very next TV programme using that mode will fail.

Please could anyone advise me where to start looking to resolve this? Thanks
#2
rtmpdump fails when it receives garbled input, but the problem is upstream and unfortunately there is nothing you can do except keep trying. The problem is unrelated to your upgrade.
#3
Thanks for your rapid reply dinkypumpkin. So am I right in thinking that choosing modes has no bearing on this? And that if a get attempt fails I should just wait a bit and try again?
#4
As you've seen, you sometimes may have better luck with lower-quality modes, but not always. There is no way to know if it will help. If not, just retry the download for a few days, at different times of day if possible.
#5
I've been trying at different times of day but no joy. Has Auntie found a way to beat get_iplayer? I can't seem to get anything now.
#6
If the problems are the same as before, the Auntie probably isn't the culprit. It's more likely your ISP or their upstream connections.
#7
I'd be surprised if it were my ISP - I know them and they don't filter anything for me, though I don't know about their upstream provider. Odd, but I just tried one download that I've been trying for days with no joy, but then tried a different TV show and it worked perfectly. And the download I first mentioned also finally worked - I deleted the partial temp file (annoyingly I was trying to resume from 97%) and that worked; a new full download was successful. All very strange - I wish I weren't so clueless!
#8
It could be a flakey router, but then you would expect that to have effects on other services. It could be wobbles at the server end, but you wouldn't expect that to happen day in and day out. It could be some problem with rtmpdump, but that's belied by the fact that many other users can use the same version of rtmdump just fine. Which leaves connectivity as a likely culprit. There doesn't have to be any filtering going on. Delays or drops in throughput - things you wouldn't notice during regular web browsing - could be at fault. Bottom line: it's virtually unknowable. What it's not is anything to do with get_iplayer per se. Without rtmdump, there would be no get_iplayer, so you have to live with its vicissitudes. rtmpdump is guaranteed to fail - a little for some people, a lot for others.
#9
Thanks dinkypumpkin, that's helpful. I've often wanted to put the router (Thomson) on a trebuchet and hurl it as far away as possible but since it belongs to a colleague I can't. Delays and drops are also a possibility that I'll look into. Since my last post, get_iplayer has worked flawlessly on half a dozen downloads.


Possibly Related Threads…
Thread Author Replies Views Last Post
  [FIXED]  Refresh throws "Mojo::Reactor::EV: Read failed" error mable syrup 3 2,112 17-08-2018, 08:54 PM
Last Post: dinky
  sh: 0: getcwd() failed: Input/output error on recording mable syrup 2 2,146 08-08-2018, 08:24 AM
Last Post: mable syrup