"The syntax of the command is incorrect" after updating to 2.99
I just updated from 2.94 to 2.99, and I am now unable to do anything with get_iplayer. Any command I enter, even commands like "-v" just displays "The syntax of the command is incorrect" in the command prompt window, and nothing I do fixes it.

I've reinstalled get_iplayer, tried running as administrator and tried running it from a different directory. Nothing has worked. The only thing I can think of that could be causing it is that my home directory is on a different drive, instead of being located on the C drive.

I'm running Windows 7 x64. Any help would be appreciated.
It is more likely to be a problem with your PATH system environment variable. See the notes in Windows installation instructions.
I've tried adding the get_iplayer directory to the PATH environment variable, but it still isn't working. I've also checked it, and it doesn't look like there are any kind of corrupted paths.

It's not that it's not finding the get_iplayer.cmd file, that works fine, it just refuses to run.
"The syntax of the command is incorrect" is a system error from Windows telling you that it can't launch get_iplayer.cmd or the commands within it. Typically that is something you might see with unquoted spaces in a path. get_iplayer.cmd manipulates the local value of %PATH%, so if the system PATH has a problem (e.g., too large or has mismatched quotes or hidden characters), it can cause problems when attempting to launch perl. Unfortunately, there is no way for us to know what is wrong on your machine. Feel free to post the output from echo %PATH% and echo %USERPROFILE%. Replace any instances of your username with XXX. Your home directory shouldn't have any bearing on this since get_iplayer won't even launch, but might as well take a look.
Turns out there was a mismatched quote in there. Works fine now, thanks anyway though.

Possibly Related Threads…
Thread Author Replies Views Last Post
  The syntax of the command is incorrect 1t3v3 0 180 17-12-2019, 02:44 PM
Last Post: 1t3v3
  Desktop and Start Menu shortcut command incorrect martinu 2 3,006 06-11-2017, 02:53 PM
Last Post: alansh
  Syntax: recording live radio (newbie) rdcuff 2 4,049 14-06-2016, 08:54 PM
Last Post: rdcuff