These forums are archived

See this post for further info

get_iplayer forums

Forum archived. Posting disabled.

web_pvr: paging of search list failing (Possibly not just Linux)


After the recent interruption of Metadata, it looks as though everything currently in my cache is being displayed in the web_pvr search tab as if it were newly downloaded. currently 551 items. I have not yet tried updating.

This shouldn't be a problem, but I found I was only able to view the first page of the list. I could change the number of items using the Programmes Per Page control in the Display tab, but that maxes out as 400 programmes. The obvious work-around is to check regularly so that there are never more than 400 new programmes, and the Metadata interruption meant that work-around fails. I have not found any mention of this anywhere in the Forums or elsewhere

None of the links that would be expected to show any page other than the first are working.

I an using Mint Linux 18.1 (an Ubuntu 16.04 LTS derivative) and have tried with Opera, Firefox, and Google Chrome browsers (all up to date). It makes no difference. Since this is a generated web page, and a basic function, it may be happening with any OS. Unless there is something about my particular set up (and it is working in every other way) I can't see any obvious reason why it should only be Linux.

Everything else worked OK. I was excluding some TV channels and recent programmes in the alphabetic listing were visible.

Opera version 43.0.2442.806
Firefox version 52.0
Google ChromeVersion 56.0.2924.87 (64-bit)

If it is working with a non-Linux browser such as Internet Explorer, that may suggest things to check, but that doesn't run on Linux, so it doesn't directly help me.

(Changing Search Filters to exclude channels in turn let me check for anything I might have missed)


get_iplayer version? Look at bottom of web pvr page.


[font=monospace]"[/font][color=#777777][font=monospace][size=small][font=verdana, sans-serif]get_iplayer Web PVR Manager v2.94"[/font][/size][/font][/color]

[color=#777777][font=monospace][size=small][font=verdana, sans-serif]It looks like that's the version still coming through the Ubuntu PPA. Does look as though I need the update, then. Upgrading now. Adding the PPA and running the Update Manager[/font][/size][/font][/color]

[color=#777777][font=monospace][size=small][font=verdana, sans-serif]I am wondering if something happens when I upgraded from Mint 18 to 18.1 I'm certainly going to  make a note to check for PPA changes next time.[/font][/size][/font][/color]

[color=#777777][font=monospace][size=small][font=verdana, sans-serif](Upgrade complete)[/font][/size][/font][/color]

[color=#777777][font=monospace][size=small][font=verdana, sans-serif]Yes, that fixed it. Thanks for the pointer.[/font][/size][/font][/color]

And those tags seem to get introduced when I do something silly like doing a cut-and-paste for a software version number. I really ought to stick to making bug reports as sonnets.

These forums are archived

See this post for further info