WARNING: Required ffmpeg utility not found - not converting .ts file
#1
Hi, I am running get_iplayer (2.96-ppa26) on a Raspberry Pi. I haven't installed ffmpeg and use avconv for conversions. And I live in Australia. I can only download radio programmes. Until recently get_iplayer served me m4a files with a bit rate of about 96.0. Since the start of December the bit rate has shot up to 320 and I get a .ts file. I get an error message:


Quote:INFO: hafhigh1,hafhigh2,hafstd1,hafstd2,dashmed1,dashmed2,hafmed1,hafmed2,dashlow1,dashlow2,haflow1,haflow2,hlsaaclow1 modes will be tried for version original
INFO: Trying hafhigh1 mode to record radio: Beat Surrender - 417. 24/09/2016

WARNING: Required ffmpeg utility not found - not converting .ts file

This reads to me like get_iplayer is looking for ffmpeg to convert the raw file but can't find that utility. This format (.ts) is not a problem for me as vlc plays it fine. And I can convert to any other format using avconv. I can't help thinking though that I am not getting the best out of get_iplayer. I did try digging into the code but by Fortran/Pascal background never reached as far as perl.

Could someone please advise:
  • do I need ffmpeg for get_iplayer to work best (I do have a procedure for compiling this but I haven't tried it yet)
  • if not is there a way I can point the utility at avconv
Cheers
#2
Read the release notes
#3
dead easy. Thanks. Sorted


Possibly Related Threads…
Thread Author Replies Views Last Post
  WARNING: Track data not found KimBo 1 1,284 28-08-2019, 04:36 PM
Last Post: dinky
  WARNING: 'overwrite' option is invalid in default options file xiatian 3 3,148 13-01-2019, 10:05 PM
Last Post: thoatswold
  Error message when converting video with tvmode=vgood Bilko 2 2,812 10-03-2017, 02:34 PM
Last Post: Bilko
  Segment not found warning: post affected programmes here dinky 12 11,786 06-08-2016, 12:12 PM
Last Post: dinky