Web PVR: reinstall required for browser to launch when shortcut run as administrator
#1
When I try to start Web PVR Manager a command prompt window opens saying "Info: Listening on 127.0.0.1:1935" then nothing happens. If I run get_iplayer_pvr from within C:\Program Files (x86)\get_iplayer CMD window opens, the saved searches run and the programmes download. I am running Web PVR Manager as administrator.
#2
Try running http://localhost:1935/ in your browser - I've got mine bookmarked.
Note: http://127.0.0.1:1935/ is equivalent.
The Web PVR Manager is listening on that port for your input.
#3
I tried running http://localhost:1935/ and http://127.0.0.1:1935/ in my browser and get "Unable to connect" error.
#4
You need to have the Web PVR Manager started in an appropriate way before using the web interface.
In Linux, this can be made to happen as a background task very easily - presumably Windows can be made to do something similar?

Haven't used Windows since XP times...
#5
I use Windows 10, and the Web PVR Manager *usually* loads correctly.
The script loads in a CMD window, it creates the server interface, and then shells to http://localhost:1935/
Occasionally the webpage refuses to load, probably because the server software took too long to go live; and I wait a few seconds then refresh the browser window. Only a couple of occasions has that failed to work. In which case I close the browser, close the CMD, and then try again.
If you always get 'unable to connect' that suggests to me there's something wrong with the software and the server interface isn't working.
Can you check if windows firewall or your antivirus software might be preventing perl from running?
Then I would download and install a new version. It might be worth using windows to remove the old version first.
There is also a folder C:\Users\<username>\.get_iplayer which might contain any changes you made to the settings; maybe some changes to the web settings are causing the problem. This might survive a reinstallation, and therefore you should consider renaming that folder first. Don't delete it because you might want to recover named searches (the pvr subfolder). And it would mean rebuilding the iplayer cache and download history.
#6
I start the player from a shortcut, which runs get_iplayer_cgi.cmd - what happens if you type that in to the cmd window instead of get_iplayer_pvr.cmd ?
#7
My shortcut runs get_iplayer_web_pvr.cmd
#8
What version of GIP and which OS and version? you don't say.

I had problems with a Windows 10 (10.0.17763 Build 17763) and GIP 3.23

Windows 10 (10.0.18363 Build 18363) it started working again and the previous build worked fine with 3.24

Linux OS 19.04 has worked consistently on all versions.
#9
I uninstalled and reinstalled the latest Get_iPlayer a number of times using the shortcut in the windows 10 start Get_iplayer folder. I tried this again this morning and checked the C:\Program Files (x86)\get_iplayer folder and noticed that the perl folder had not been removed. After manually deleting this and reinstalling Get_iPlayer everything is working correctly.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Web PVR: 'Back' button no longer works in Edge browser bfrost 4 6,500 15-03-2018, 03:10 PM
Last Post: bfrost
  Desktop and Start Menu shortcut command incorrect martinu 2 2,795 06-11-2017, 02:53 PM
Last Post: alansh
  Stop loading browser on Web manager launch plip 2 3,356 10-07-2017, 05:37 PM
Last Post: plip
  Cannot launch web pvr from start menu johannis 0 1,826 10-07-2017, 04:19 PM
Last Post: johannis