listen and ports options not working in 3.22
Hi all,

I've recently upgraded from 3.20 to 3.22 on Ubuntu. Went through the usual steps of swapping out get_iplayer and get_iplayer.cgi as I have done periodically when things break - I noticed that my cache hadn't updated in days, which prompted the upgrade.

The problem is that it (the cgi/web) won't start. I eventually tracked it down to the fact that the --listen and --port options have been removed and there is no way to pass these variables in to my (server) start script. The error from the cgi:

Unknown option: listen
Unknown option: port

I've also tried the -l and -p options (and the -g), but the -p fails at line 1834 as it thinks it is a proxy port.

I've searched around and tried a number of things, but can't get it to start. I can't even get it to start with no parameters i.e. just running a local ./get_iplayer.cgi

I'm running bionic LTS and my kernel is 4.15.0-58-generic

Hope someone can help...
I've since pulled down get_iplayer.cgi v3.21 and running it with get_iplayer v3.22 in the meantime, which appears to be working.

Points to a bug in v3.22 of get_iplayer.cgi
I can't reproduce your problem.

If you use the get_iplayer repository on launchpad (see then it comes with get_iplayer_web_pvr which runs the (unsupported) cgi interface on the address and port specified in /etc/default/get_iplayer_web_pvr.  It's been that way since I borrowed the packaging from debian back at version 2.something.

And I can't make the get_iplayer.cgi break in the way you describe either.

Some exact command lines and the full actual output would help.


PS. incidentally, by way of example, I get this:
$ /usr/share/get_iplayer/get_iplayer.cgi --port 8080 --listen
INFO: Listening on
WARNING: Insecure Remote access is allowed, use --listen= to limit to this host only
This means you're not invoking the web pvr:
(01-09-2019, 11:28 AM)europa Wrote: Unknown option: listen
Unknown option: port
This means you're invoking get_iplayer CLI instead with invalid options:
(01-09-2019, 11:28 AM)europa Wrote: I've also tried the -l and -p options (and the  -g), but the -p fails at line 1834 as it thinks it is a proxy port.
Your problem is between you and your scripts. As @jonhedgerows has already said, get_iplayer is working fine on Ubuntu. No options have been removed - be sure of your facts before you make such assertions. If you can't get the PPA release to work, start another thread and follow our instructions to provide a proper report so we can see what is happening on your system. This thread is closed.