Cannot download programmes with PIDs beginning with 'm' using obsolete get_iplayer
Since July 21, there has been a change in the URL of Radio 3 programmes:

Before, the URL ended with the PID : string of 8 characters, beginning with "b0"

Since then, the last segment of the URL always begins with "m0"

And the result is that I cannot download anymore.
I tried using the command lines :
1)   get_iplayer --pid=m00006p1 --type=radio
2)   get_iplayer
and all failed.
I also tried with other programmes whose identifier begins with "m0", and none of them worked.
Are you running the latest get_iplayer?

I have been successfully downloading the Proms and today's two downloads are m0 pids.
get_iplayer --pid=m00006p1
works fine here (copied from a somewhat truncated screen width):

C:\Program Files\get_iplayer>get_iplayer --pid=m00006p1
get_iplayer 3.17.0-MSWin32, Copyright (C) 2008-2010 Phil Lewis
This program comes with ABSOLUTELY NO WARRANTY; for details use --warranty.
This is free software, and you are welcome to redistribute it under certain
conditions; use --conditions for details.

Edinburgh International Festival - 2018 Queen's Hall Series, Dorothea Roschmann and Roger Vignoles, BBC iPlayer, m00006p
INFO: 1 total programmes

INFO: Downloading radio: 'Edinburgh International Festival: 2018 Queen's Hall Series - Dorothea Roschmann and Roger Vign
oles (m00006p1) [original]'

<rest omitted>
Upgrading to the latest version of get_iplayer fixed the problem, I should have started there !
Sorry for the trouble and thank your for your replies.

I have been using the following successfully to d/l radio

get_iplayer --pid XXXXXXX --modes=hafhigh

This was when the page urls were like TV programmes, for example -

But the urls on iplayer have changed to this -

I am getting this message: ERROR: Could not extract a valid PID from m0000bp7

Any ideas anyone?

Thanks in advance
Works ok for me using version 3.17. What version are you on, rubber_glover?
Is aunty messing around again?...The PID`s for radio progs that always began with "b"
seem to have changed to "m" and im now getting this message from GI-PLYR "error could not extract a valid PID from m0000n3g
any one else getting this?
Ok...HUGE thanks to whoever spotted my schoolboy error in creating a new thread and merged it with this a fresh download sorted the issues...thanks guys,much appreciated

Possibly Related Threads...
Thread Author Replies Views Last Post
  Can't download defunct Highlands and Islands schedule page with obsolete get_iplayer mediapenguin 5 2,101 22-11-2018, 06:03 PM
Last Post: mediapenguin
  BBC multiple PIDs for same(?) programme mable syrup 3 1,296 02-11-2018, 10:41 AM
Last Post:
  --pid-recursive not working with broken obsolete version of get_iplayer Dranok 3 1,200 01-11-2018, 12:06 PM
Last Post: dinky
Bug [FIXED]  Cannot download recent World Service programmes with PIDs starting with "w" cje768 4 3,950 20-08-2017, 11:18 PM
Last Post: dinky