How do I copy output file with --command using Windows FTP client?
#1
Hello,

this has got me stumped and I was wondering if somebody can point me to a solution.

I have been using COMMAND to copy downloaded files to a different directory.

However, I would now like to copy these files, as soon as they get downloaded, to a Humax HD Recorder, which is accessible through FTP.

In all the trials I did, I could not manage to pass the <filename> parameter to the FTP command in Windows.

How can I solve this?

What else could I do?

What could be a solution to copy a downloaded program to a FTP server?

The reason I want to do this is to have the recordings downloaded using GIP immediately available on the Humax, because its interface is more usable for a member of my family who is unfortunately unable to turn on the PC and use the PC to view the program.

TIA

Lorenz
#2
There is a piece of software called Webdrive. I don't know if this will do what you want.

With this you assign a drive letter to an FTP folder. You can then download directly to that 'drive'. I don't know if this will work with data coming from something like iPlayer though.

There is a 10-day free trial so you can test it and it's not horrendously expensive if it solve your issue.

https://southrivertech.com/products/webdrive/
#3
Without detail of the errors you're getting it's difficult to solve.

I suspect your problem's to do with escaping and quoting various characters. The escape character in the Windows command shell is the caret ^ and special characters that may need escaping or quoting are: <space> & ( ) [ ] { } ^ = ; ! ' + , ` ~. For get_iplayer the escape character is the backslash \ and for your ftp program you'll have to look at the documentation. Doubling-up embedded double-quotes may also be necessary.

Have you tried something like the following, which should get the command successfully through the Windows shell to get_iplayer?
Code:
get_iplayer --command "ftp put ""<filename>"" moreFtpArgs" --moreGipArgs
Hope this helps.
#4
I'd like to thank you all for the comments and pointers to a solution.

The issue was that I wanted to copy what I download using GIP to a Humax HD recorder to allow a member of my family (who is familiar with operating the Humax but not a computer) to watch recordings.

With all the help here, I solved the problem using WinSCP as an FTP client.

On my system, GIP outputs to J:\Videos\iPlayer Recordings on the PC, while I wanted the copies to go to "My Video/iPlayer" on the Humax main HD.
humaxftp and 0000 are the default username and password for the Humax FTP server.

I added to the options file in %USERPROFILE%\.get_iplayer\ the following line

Code:
command "C:\Program Files (x86)\WinSCP\WinSCP.com" /command "open ftp://humaxftp:0000@192.168.1.21/ -passive=0" "lcd ""J:\Videos\iPlayer Recordings""" "cd ""/mnt/hd2/My Video/iPlayer""" "put ""<filename>""" "exit"

Note the single, double, triple quotes.
I suspect other FTP clients will also allow a similar syntax.
I could not figure out how to pass <filename> to Windows' own FTP client.

mastermonkey mentioned Webdrive as way to assign a letter to an FTP directory.
Following their lead, I also discovered but did not try:
FTP drive  http://www.killprog.com/fdrve.html
FTP Use https://www.ferrobackup.com/map-ftp-as-disk.html
Drivemaker http://backupchain.com/en/drivemaker/
All freeware

HIH

Lnz


Possibly Related Threads...
Thread Author Replies Views Last Post
  Made a typo in output directory value - where did my file go? pwl2706 1 1,198 11-10-2018, 02:09 AM
Last Post: kamelne
  get_iplayer unable to copy cache? betty77 4 2,695 04-07-2017, 10:16 AM
Last Post: dinky
  "Error opening file for writing" when installing get_iplayer 3.oo on Windows alansh 5 3,643 01-05-2017, 04:40 PM
Last Post: janus
  Invalid chars error in --command-radio (Windows) Roll_Fizzlebeef 4 2,158 11-02-2017, 02:03 AM
Last Post: Roll_Fizzlebeef