[INVALID] Homebrew ffmpeg - dyld: Library not loaded: /usr/local/opt/jack/lib/libjack.0.dylib
#1
Am wondering if anyone might be able to help.  

I can successfully download a programme but the auto remux from a .ts file to an mp4 fails.  I thought it might be ffmpeg but that's up to date.  It says that a library is not loaded (libjack.0.dylib) - and, wouldn't you know, I have no idea how to sort it.  

If you can help I'd be very grateful.
  • Mac OS 10.13.3
  • get_iplayer version: 3.12-homebrew
  • ffmpeg is up to date.



Code:
Matches:
192: Art, Passion & Power: The Story of the Royal Collection: Series 1 - Palaces and Pleasuredomes, BBC Four, b09q02kn
INFO: 1 matching programmes
WARNING: A UK TV licence is required to access BBC iPlayer TV content legally
INFO: Downloading tv: 'Art, Passion & Power: The Story of the Royal Collection: Series 1 - 3. Palaces and Pleasuredomes (b09q02kn) [original]'
sh: line 1: 51489 Abort trap: 6           "ffmpeg" -version 2>&1
INFO: Downloaded: 1100.39 MB (00:59:00) @ 41.92 Mb/s (hlshd1) [audio+video]    
INFO: Converting to MP4
dyld: Library not loaded: /usr/local/opt/jack/lib/libjack.0.dylib
 Referenced from: /usr/local/bin/ffmpeg
 Reason: image not found
INFO: Command exit code 2 (raw code = 6)
ERROR: Conversion failed - retaining video file: /Users/########/Desktop/Art_Passion_Power_The_Story_of_the_Royal_Collection_Series_1_-_3._Palaces_and_Pleasuredomes_b09q02kn_original.hls.ts
INFO: Skipping all versions of this programme
#2
It's right there in the output you posted. Your ffmpeg installation is broken, so take the issue to Homebrew support forums. It has nothing to do with get_iplayer. Thread closed.
#3
The latest ffmpeg from Homebrew (3.4.1_1) is apparently built with a dependency on libjack, which I assume is a mistake. Report this in the Homebrew forums so it can be fixed. You can work around the problem by installing the jack package to provide the missing ffmpeg dependency, though that installs a few other packages you also don't need. You may also be able to use brew switch to roll back ffmpeg and x264 to previous versions (the update to ffmpeg was to accomodate an update to x264). And of course you can download a static build of ffmpeg to use temporarily. However, the best course of action is simply to notify Homebrew and wait for a fix.
#4
Now fixed in Homebrew ffmpeg 3.4.1_2


Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED]  (Homebrew) WARNING: Required ffmpeg utility not found - not converting .ts file(s) cathorn 3 1,277 13-12-2017, 12:33 PM
Last Post: dinky