Version 2.87 fails to even start up - issue with get_iplayer.pl line 74
#1
Not sure whether the issue stems from using get_iplayer_setup_4.8 and saying no to downloading latest installer, but I have managed to download version 2.87 using 4.8 and I get the following message upon running the get_iplayer command prompt from the start menu tile:-

Can't locate Unicode/Normalize.pm in @INC (@INC contains: C:/Program Files (x86)
/get_iplayer/lib .) at get_iplayer.pl line 74.
BEGIN failed--compilation aborted at get_iplayer.pl line 74.

I have uninstalled get_iplayer twice and re-installed now with no difference. All I can do is replace the get_iplayer.pl file with my backup copy from 2.86, which naturally runs version 2.86 with no problems.

I cannot run the latest installer as Kaspersky detetcts it as both a virus and malware and deletes it before I can do anything. Not particularly happy to turn Kaspersky off to use the installer.

Any suggestions or tweaks I can do to edit the 2.87 get_iplayer.pl file (directed at a novice)? I need this sorted to get some programms that are over the 7 day threshold via PID before they get taken off iPlayer.

Thanks in advance.
#2
That's why the release notes say you must use the latest installer. The embedded Perl requires an upgrade to work with 2.87. As for Kaspersky, that's your decision. Every new installer throws up false positives. If you want to install get_iplayer manually, go to the installation guides in the wiki and read the manual installation instructions for Windows.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Web PVR fails to start properly - 3.20 alansh 0 1,875 02-03-2019, 04:41 PM
Last Post: alansh
  Not a scalar reference error at get_iplayer.pl line 7099 on Shark Episode 1 brassing 16 14,319 19-06-2015, 05:29 PM
Last Post: SquarePenguin
  Web PVR fails with "cannot fork at get_iplayer.cgi line 328" alansh 1 2,492 15-06-2015, 12:05 PM
Last Post: dinky