[FIXED] --pid-recursive doesn't work for CBBC and CBeebies series
I've only recently discovered the --pid-recursive command, and overnight managed to download all the Doctor Who episodes which is brilliant!

However, when i tried using it on some CBeebies content the command failed, returning 0 episodes.
I saw this issue on a previous forum post, which said it was filed in v3.13

I'm on 3.14 and the issue appears to be still present
C:\Users\nevla>get_iplayer --pid-recursive --pid b01j9sth
get_iplayer 3.14.0, Copyright (C) 2008-2010 Phil Lewis
 This program comes with ABSOLUTELY NO WARRANTY; for details use --warranty.
 This is free software, and you are welcome to redistribute it under certain
 conditions; use --conditions for details.

INFO: 0 total programmes

Am i using it wrong - or is it at the BBC end again?
Thanks for the report. This is due to another change at the BBC end. Should only affect CBBC and CBeebies for the most part. Will fix in next release. Anyone who can't wait: In the get_iplayer(.pl) script, find the string "list__grid__item" and change to "grid__item". Should only be one instance, on line 5075 in v3.14.
Hi I am having a problem using --pid-recursive to record a series (The Next Step). It was working last week with the command:

"C:\Program Files (x86)\get_iplayer\get_iplayer" --pid b05qvqn5 --pid-recursive --subtitles

however the display now indicates there are 0 programmes found: "INFO: 0 total programmes" despite the iplayer web page saying there are currently 35 episodes available. Some other TV shows seem to be working ok, so maybe the problem is just with this one, if so is there a fix? Many thanks

Many thanks for the merge, sorry I didn't see this thread before. I applied the suggested fix and now it is all working again :)

Make the fix with care - 'Bitz and Bob' still works ok for me (v3.1.3.0)
get_iplayer --pid b09w6m2v --modes best --pid-recursive

I'm still working through my list of CBeebies programmes, there may be more
I'll install v3.14 in a minute and see if it's the same

It still works in v3.14
All the others I tried fail with 'INFO: 0 total programmes'

For everyone else: There is no need to take any special care, other than to apply the change as indicated. I shouldn't need to say this, but the suggested fix will not affect CBBC or CBeebies programmes that already work with --pid-recursive. Thread closed.
fixed in v3.15

Possibly Related Threads…
Thread Author Replies Views Last Post
  [FIXED]  --subtitles-only w/--pid-recursive on mixed tv/radio series (Glasto) is unsupported mr-b 2 3,057 14-07-2019, 02:26 AM
Last Post: dinky
  [FIXED]  --pid-recursive doesn't work for all non-CBBC/Cbeebies TV and radio series ermax 10 7,961 06-07-2018, 02:55 AM
Last Post: kleh
  Why doesn't Doctor Who box set appear in search results? encore 6 6,405 23-06-2018, 11:28 PM
Last Post: Linnaeus
  [FIXED]  No episodes found using --pid-recursive on CBBC/CBeebies programmes swaleuser 2 4,360 24-03-2018, 07:59 PM
Last Post: dinky