get_iplayer forums

[DONE] Monochrome Subtitles with --subs-embed - Printable Version

+- get_iplayer forums (https://forums.squarepenguin.co.uk)
+-- Forum: General Forums (https://forums.squarepenguin.co.uk/forum-16.html)
+--- Forum: Feature Requests (https://forums.squarepenguin.co.uk/forum-7.html)
+---- Thread: [DONE] Monochrome Subtitles with --subs-embed (https://forums.squarepenguin.co.uk/thread-2040.html)



Monochrome Subtitles with --subs-embed - User 04 - 19-06-2019

Running get_iplayer 3.20.0-MSWin32 from a Microsoft Windows 7 Home Premium (Version 6.1.7601) CMD shell.

Since subtitles embedded into an mp4 container will always be monochrome when using the mov_text codec of ffmpeg, could these embedded subtitles always follow the --subs-mono format with a leading hyphen used to denote a change of speaker? This may require a second call to the ttml_to_srt function with a mono argument of true to create a temporary srt file for embedding.

It is currently possible to run get_iplayer twice to achieve this behaviour:
Code:
C:\>get_iplayer --subtitles --subs-mono --subs-embed <other options> --pid p07b3shn
C:\>get_iplayer --subs-only --no-subs-mono --overwrite <other options> --pid p07b3shn
This work-around does, of course, require unnecessarily re-downloading the jsons and re-streaming the ttml, which is a bit of a waste of resources.

Thanks in advance for considering this.


RE: Monochrome Subtitles with --subs-embed - dinky - 14-07-2019

From v3.21, --subs-embed implies --subs-mono