get_iplayer forums

Full Version: Tagging fails, seemingly randomly
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Firstly, a huge thank you for such an awesome application. As a developer, I know what it takes to put something like this together and I am very grateful for the work put in to produce this.

Now to the question...

I have an intermittent issue (maybe once every 20-30 downloads) where the MP4 tagging fails with exit code 255 (Raw code 65280), if I delete and force a retry it usually works ok.


I understand that the tagging is done by Atomicparsley, but I couldn't seem to find anything on these error codes to assist in debugging this issue. Initially I thought that it was caused by my backup software being overzealous and trying to backup my shared folder whilst writing them, but I've moved the download to a different (not backed up) folder and then move the resultant files to the shared folder by running a batch file, but this has not solved the issue.

get_iplayer is running on my home server which is Windows 2012 R 2. Currently I am using version 3.12.0

Any pointers?

Many thanks
There is nothing get_iplayer can do about AP failures. If your get_iplayer output directory is on a network drive, there is more risk that AtomicParsley will flake out due to I/O problems, but writing to a local drive is not a guarantee of success. If the AP temp file is left behind, check if it has been tagged. AP may fail right at the end when overwriting the original file with the tagged version (due to disk or path problem), in which case you can simply rename the file yourself. That's what the error code suggests, but no way for me to know. Aside from that, you can run with --log-progress --verbose to ensure you see all AP output. There may be additional clues there because AP unfortunately writes some error messages to its stdout, which is normally not shown by get_iplayer.